summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkomeil Parseh2023-01-21 20:34:15 +0330
committerkomeil Parseh2023-01-21 20:34:15 +0330
commit303b98679a335cfd90ceb18e2bcd0c843df3979a (patch)
tree0140f013558997ce9f032220ef40ce613163c2ac /PKGBUILD
parent8bf280a561f1cb7df036c4b52a6218dfd2c8342c (diff)
downloadaur-303b98679a335cfd90ceb18e2bcd0c843df3979a.tar.gz
release(0.5.0): release new version
Added Stat#format(theme) to create styled stats Stat#style_label to style the label without mutating the original Stat instance Plugin#matches_path? and Plugin#from_path to allow plugins to initialize from paths, not just git repositories Changed Bitbucket Cloud header to be bold and blue Stat#style_label! to accept one or more styles as parameters Plugin#matches_repo? to return false instead of raising an error when it is not overridden Fixed length of separator to match visual length of header Potentially Breaking for 3rd-party Plugins Changed Repofetch::Util to be a module clean_s to be called remove_format_params Moved default_remote and default_remote_url to be in Repofetch::Util Stat#to_s to return an unstyled value Header text and stats will now automatically be bold and use the value returned by Plugin#primary_color
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1853bb67f81c..0f819bd58b90 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=ruby-repofetch-bin
_gemname=repofetch
-pkgver=0.4.3
+pkgver=0.5.0
pkgrel=1
pkgdesc="A remote repository stat fetcher with support for 3rd-party plugins"
arch=("any")
@@ -16,7 +16,8 @@ provides=("ruby-repofetch")
conflicts=("ruby-repofetch" "ruby-repofetch-bin")
source=("https://rubygems.org/downloads/$_gemname-$pkgver.gem")
noextract=("$_gemname-$pkgver.gem")
-md5sums=("027f72b3e39efd824890a6a28706baa8")
+md5sums=("d9c8aa0be7316b7439caf4c96242d6e4")
+
package() {
local _gemdir="$(ruby -e "puts Gem.default_dir")"