summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkomeil Parseh2023-01-13 17:36:42 +0330
committerkomeil Parseh2023-01-13 17:36:42 +0330
commit8bf280a561f1cb7df036c4b52a6218dfd2c8342c (patch)
tree6a9b17d9ee9c9ed5c5eb8f33fbc223744d01356c /PKGBUILD
parent45939c34e7da1d8cb2f9110ac3155ab4f4ac21e3 (diff)
downloadaur-8bf280a561f1cb7df036c4b52a6218dfd2c8342c.tar.gz
release(1.4.3): release new version
+ Added - Bitbucket Cloud plugin - Simple help message for the GitLab plugin (`repofetch --plugin Repofetch::Gitlab -- --help`) - `--path` option, which is an alias for `--repository` - SSH url stat to GitHub and GitLab plugins + Changed - "URL" stat in GitHub and GitLab plugins to "HTTP(S)" - GitLab header to be styled + Fixed - Confusing error on incorrect CLI args for the GitLab plugin + Breaking for users + Changed - The `--plugin` short option to `-P` - `-p` to be the short option for `--path` + Breaking for 3rd-party plugins + Changed - The exception that is caught when initializing a plugin from ArgumentError to `Repofetch::PluginUsageError`
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 54dbbdeb8e29..1853bb67f81c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=ruby-repofetch-bin
_gemname=repofetch
-pkgver=0.4.2
+pkgver=0.4.3
pkgrel=1
pkgdesc="A remote repository stat fetcher with support for 3rd-party plugins"
arch=("any")
@@ -16,8 +16,7 @@ provides=("ruby-repofetch")
conflicts=("ruby-repofetch" "ruby-repofetch-bin")
source=("https://rubygems.org/downloads/$_gemname-$pkgver.gem")
noextract=("$_gemname-$pkgver.gem")
-md5sums=("269ebe3228bbffe7d35ada1cb2c77c2b")
-
+md5sums=("027f72b3e39efd824890a6a28706baa8")
package() {
local _gemdir="$(ruby -e "puts Gem.default_dir")"
@@ -32,3 +31,4 @@ package() {
install --verbose -D --mode=0644 $pkgdir/$_gemdir/gems/$_gemname-$pkgver/*.md --target-directory "${pkgdir}/usr/share/doc/${pkgname}"
}
+