summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAnatoly Bashmakov2020-08-08 22:49:06 +0300
committerAnatoly Bashmakov2020-08-08 22:49:06 +0300
commit68e1e4c02e0b2ebeda5612ee55b00bc358023619 (patch)
tree949a72357188e261d8f9517ca6d0650c46b941ea /PKGBUILD
downloadaur-68e1e4c02e0b2ebeda5612ee55b00bc358023619.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e307243a52f8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Anatoly Bashmakov <anatoly at posteo dot net>
+
+_gemname=sinatra-contrib
+pkgname=ruby-$_gemname
+pkgver=2.0.8.1
+pkgrel=1
+pkgdesc='Collection of useful Sinatra extensions'
+arch=(any)
+url='http://sinatrarb.com/contrib/'
+license=(MIT)
+depends=(ruby
+ ruby-sinatra
+ ruby-mustermann
+ ruby-backports
+ ruby-tilt
+ ruby-rack-protection
+ ruby-multi_json)
+options=(!emptydirs)
+source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
+noextract=($_gemname-$pkgver.gem)
+sha1sums=('400d357e0d491fb2a0a02eaffedcfd19e4b21470')
+
+package() {
+ local _gemdir="$(ruby -e 'puts Gem.default_dir')"
+ gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+ rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
+ install -D -m644 "$pkgdir/$_gemdir/gems/$_gemname-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}