summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMario Finelli2015-06-08 23:25:54 -0400
committerMario Finelli2015-06-08 23:25:54 -0400
commit0cbe4e2d1f406cf3e3289c6d6894f7698b1143d7 (patch)
tree8cce5d5a2515ccd6482b179029aaca8ac63ecac4 /PKGBUILD
downloadaur-0cbe4e2d1f406cf3e3289c6d6894f7698b1143d7.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD74
1 files changed, 74 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..51d22e879b17
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,74 @@
+# Maintainer: Mario Finelli <mario dot finelli at yahoo dot com>
+# Contributor: Tom Richards <tom at tomrichards dot net>
+# Contributor: Alexsandr Pavlov <kidoz at mail dot ru>
+# Contributor: Ernie Brodeur <ebrodeur at ujami dotnet>
+# Contributor: Rogof <fake dot bios at gmail dot com>
+# Contributor: m4.rc0 <m4 dot rc0 at o2 dot pl>
+
+pkgname=rubymine
+_pkgname=RubyMine
+pkgver=7.1.2
+pkgrel=2
+pkgdesc="Ruby and Rails IDE with the full stack of essential developer tools."
+arch=('i686' 'x86_64')
+options=(!strip)
+url="https://www.jetbrains.com/ruby/"
+license=('custom')
+depends=('java-environment' 'desktop-file-utils' 'gtk-update-icon-cache')
+optdepends=('ruby: Ruby run/debug support')
+install=rubymine.install
+source=(https://download.jetbrains.com/ruby/${_pkgname}-${pkgver}.tar.gz
+ rubymine.desktop
+ rubymine.install)
+sha256sums=('b2bed0a8612d75b1a1470713bd14301eb8961f1f7dd273a1b6d942593625e1bf'
+ '72df0e7c605caf7b6c98e9335f4eee9c8bfe8fcc24523634fd8c1ebe019534d6'
+ '7ecadddf2b315b22df3a5c7b90e18be7ea69e2a0d869ee18bf0e031b2c508f76')
+
+prepare() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ # Remove junk
+ rm "build.txt"
+ rm "Install-Linux-tar.txt"
+
+ #Remove non-linux libs
+ rm -rf "lib/libpty/macosx"
+ rm -rf "lib/libpty/win"
+
+ #Remove bin/libs if architecture doesn't match
+ if [[ $CARCH = 'i686' ]]; then
+ rm -f "bin/fsnotifier64"
+ rm -f "bin/libbreakgen64.so"
+ rm -f "bin/libyjpagent-linux64.so"
+ rm -f "bin/rubymine64.vmoptions"
+ rm -rf "lib/libpty/linux/x86_64"
+ fi
+ if [[ $CARCH = 'x86_64' ]]; then
+ rm -f "bin/fsnotifier"
+ rm -f "bin/libbreakgen.so"
+ rm -f "bin/libyjpagent-linux.so"
+ rm -f "bin/rubymine.vmoptions"
+ rm -rf "lib/libpty/linux/x86"
+ fi
+}
+
+package() {
+ cd "${srcdir}"
+ [ $CARCH == "x86_64" ] && SUFFIX=64
+
+ #Pre-packaged program files
+ install -d -m 755 "${pkgdir}/usr/share"
+ cp -a "${srcdir}/${_pkgname}-${pkgver}" "${pkgdir}/usr/share/${pkgname}"
+
+ #Desktop application
+ install -Dm644 "${pkgdir}/usr/share/${pkgname}/bin/RMlogo.svg" "${pkgdir}/usr/share/icons/hicolor/scalable/apps/${pkgname}.svg"
+ install -Dm644 "rubymine.desktop" "${pkgdir}/usr/share/applications/rubymine.desktop"
+ install -d -m 755 "${pkgdir}/usr/bin"
+ ln -s "/usr/share/${pkgname}/bin/${pkgname}.sh" "${pkgdir}/usr/bin/jetbrains-${pkgname}"
+
+ #License
+ install -Dm644 "${srcdir}/${_pkgname}-${pkgver}/license/${_pkgname}_license.txt" "${pkgdir}/usr/share/licenses/${pkgname}/license.txt"
+
+ #Java config
+ sed -i 's/lcd/on/' "${pkgdir}/usr/share/rubymine/bin/rubymine${SUFFIX}.vmoptions"
+ echo "-Dswing.aatext=true" >> "${pkgdir}/usr/share/rubymine/bin/rubymine${SUFFIX}.vmoptions"
+}