summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMax Weber2022-01-04 23:17:32 -0700
committerMax Weber2022-01-04 23:17:32 -0700
commit5f6fd73b771ef4be7bda13efcd177c267505a266 (patch)
treed08b2519074ce26dceb54694e4475fae4b521dac /PKGBUILD
parent57af3006525aa351e47e5bc50e024f1835c952f4 (diff)
downloadaur-5f6fd73b771ef4be7bda13efcd177c267505a266.tar.gz
include version in sources
makepkg is too dumb to redownload stuff if it doesn't verify
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ff60802e2461..944ae4178cfc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,9 +16,9 @@ optdepends=(
'gvfs: enable links'
'libnotify: native tray notifications')
makedepends=()
-source=("https://github.com/runelite/launcher/releases/download/${pkgver}/RuneLite.jar"
- "RuneLite.LICENSE::https://raw.githubusercontent.com/runelite/launcher/${pkgver}/LICENSE"
- "https://raw.githubusercontent.com/runelite/launcher/${pkgver}/appimage/runelite.png"
+source=("${pkgver}_RuneLite.jar::https://github.com/runelite/launcher/releases/download/${pkgver}/RuneLite.jar"
+ "${pkgver}_RuneLite.LICENSE::https://raw.githubusercontent.com/runelite/launcher/${pkgver}/LICENSE"
+ "${pkgver}_runelite.png::https://raw.githubusercontent.com/runelite/launcher/${pkgver}/appimage/runelite.png"
runelite.desktop)
noextract=('RuneLite.jar')
sha256sums=('758e71ef44e67f09b143af953f1cf2a38578a9ec181ed8de52c4a6a5d32ebde8'
@@ -28,7 +28,7 @@ sha256sums=('758e71ef44e67f09b143af953f1cf2a38578a9ec181ed8de52c4a6a5d32ebde8'
package() {
install -D -m644 \
- "${srcdir}/RuneLite.jar" \
+ "${srcdir}/${pkgver}_RuneLite.jar" \
"${pkgdir}/usr/share/java/runelite/RuneLite.jar"
install -D -m644 \
@@ -36,11 +36,11 @@ package() {
"${pkgdir}/usr/share/applications/runelite.desktop"
install -D -m644 \
- "${srcdir}/runelite.png" \
+ "${srcdir}/${pkgver}_runelite.png" \
"${pkgdir}/usr/share/pixmaps/runelite.png"
install -D -m644 \
- "${srcdir}/RuneLite.LICENSE" \
+ "${srcdir}/${pkgver}_RuneLite.LICENSE" \
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -D -m755 \