summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIvan Puntiy2016-02-19 16:06:16 +0200
committerIvan Puntiy2016-02-19 16:06:16 +0200
commit51d9e03fb25f271f0226f95c51cbbb8cd4600333 (patch)
treeb8b265bc172e5ba80f0147ca10a1a3165d869ef1 /PKGBUILD
downloadaur-51d9e03fb25f271f0226f95c51cbbb8cd4600333.tar.gz
First beta release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6f34be2dd472
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Ivan Puntiy <ivan.puntiy-at-gmail>
+
+pkgname=runescape-launcher
+pkgver=2.0.6
+pkgrel=1
+pkgdesc="RuneScape Game Client"
+arch=(x86_64)
+url="http://www.runescape.com/"
+license=('GPL')
+depends=(
+ glibc libcurl-compat libvorbis sdl2 webkitgtk2
+ libpng12 glew1.10
+ desktop-file-utils
+)
+install=$pkgname.install
+source=("http://content.runescape.com/a=13/downloads/ubuntu/pool/non-free/r/$pkgname/${pkgname}_${pkgver}_amd64.deb")
+sha256sums=('b59ef54de67abd362b6f32ae3a32a170470c51d2912780b6ae76fb0982dbacf0')
+
+package() {
+ cd "$pkgdir"
+ bsdtar -xf "$srcdir/data.tar.xz"
+
+ # remove /usr/share/games
+ mv usr/share/games/$pkgname usr/share/
+ rmdir usr/share/games
+ sed -i -e 's:/usr/share/games:/usr/share:g' usr/bin/$pkgname usr/share/applications/$pkgname.desktop
+
+ # libcurl-compat
+ sed -i -e 's:\(/usr/share/runescape-launcher/runescape \):LD_PRELOAD=libcurl.so.3 \1:' usr/bin/$pkgname
+}