summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMantas Mikulėnas2016-02-19 12:59:18 +0200
committerMantas Mikulėnas2016-02-19 13:52:34 +0200
commit667e68d0ec0a13170a29c0b39237dc63c7f52d58 (patch)
tree428cb9163a76e3cd4d7341048367fe58df771b19 /PKGBUILD
downloadaur-667e68d0ec0a13170a29c0b39237dc63c7f52d58.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..70e798a052e3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Upstream: RuneScape Linux <noreply@jagex.com>
+
+pkgname=runescape-launcher-nxt
+pkgver=2.0.6
+pkgrel=1
+pkgdesc="RuneScape MMORPG – NXT client core"
+arch=(x86_64)
+license=(custom)
+uri="https://www.runescape.com/"
+depends=(
+ gcc-libs
+ glew1.10
+ libcurl-compat
+ libvorbis
+ sd2_mixer
+ sdl2
+ sdl2_gfx
+ webkitgtk2
+)
+source_x86_64=("http://content.runescape.com/a=946/downloads/ubuntu/pool/non-free/r/runescape-launcher/runescape-launcher_${pkgver}_amd64.deb")
+sha256sums_x86_64=('b59ef54de67abd362b6f32ae3a32a170470c51d2912780b6ae76fb0982dbacf0')
+
+prepare() {
+ bsdtar xf control.tar.gz
+ bsdtar xf data.tar.xz
+}
+
+package() {
+ cp -a usr "$pkgdir"
+ sed -i '1aexport LD_PRELOAD="/usr/lib/libcurl.so.3"' "$pkgdir"/usr/bin/runescape-launcher
+ install -Dm0644 copyright "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+# vim: ft=sh:ts=4:sw=4:et