summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicholas Boyd Isacsson2020-07-29 17:16:38 +0200
committerNicholas Boyd Isacsson2020-07-29 17:16:38 +0200
commita64d165f8dc91d9f3ad4052c6fc2dad001b5b693 (patch)
treed12ed0add17d6354e7ac51184c74c214ecf9b4e5 /PKGBUILD
downloadaur-a64d165f8dc91d9f3ad4052c6fc2dad001b5b693.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..07926670ba57
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Nicholas Boyd Isacsson <nicholas@isacsson.se>
+
+pkgname=runin
+pkgver=r2.a9636d1
+pkgrel=1
+pkgdesc='Launch a terminal to run a command, passing on stdin & stdout'
+arch=('any')
+url="https://github.com/nichobi/${pkgname}"
+license=('GPL3')
+depends=('bash')
+makedepends=('git')
+provides=('ronin')
+source=(git+$url)
+md5sums=(SKIP)
+
+pkgver() {
+ cd "${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ install -vDm 755 runin -t "${pkgdir}/usr/bin/"
+}
+