summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormurlakatamenka2020-01-28 18:50:46 +0300
committermurlakatamenka2020-01-28 18:50:46 +0300
commit20b567fa7d37ad9106d78988189b365269f5a8ae (patch)
tree4098839676d24639a1d9a86de730b76d0bae8b31 /PKGBUILD
parente2cc4709ffd6bd2e73a644ada8268ac0e1541698 (diff)
downloadaur-20b567fa7d37ad9106d78988189b365269f5a8ae.tar.gz
Fix source variable to generate unique filename (thanks to amesgen!)
Details: - https://aur.archlinux.org/packages/rust-analyzer-bin/#comment-726698 - https://wiki.archlinux.org/index.php/PKGBUILD#source
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 97d341aca973..574cc48e0d58 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
pkgname=rust-analyzer-bin
pkgver=20200127
_pkgver='2020-01-27'
-pkgrel=1
+pkgrel=2
pkgdesc="An experimental Rust compiler front-end for IDEs. Binary build."
arch=('x86_64')
url="https://github.com/rust-analyzer/rust-analyzer"
license=('MIT' 'Apache')
provides=('rust-analyzer')
conflicts=('rust-analyzer' 'rust-analyzer-git' 'rust-analyzer-vscode-git')
-source=("ra_lsp_server::$url/releases/download/$_pkgver/ra_lsp_server-linux")
+source=("ra_lsp_server-$_pkgver::$url/releases/download/$_pkgver/ra_lsp_server-linux")
md5sums=('7ee3e7ac47fc418c360a0c33a0ffc339')
pkgver() {
@@ -19,5 +19,5 @@ pkgver() {
package() {
cd "$srcdir"
- install -Dm 755 "ra_lsp_server" -t "$pkgdir/usr/bin/"
+ install -Dm 755 "ra_lsp_server-$_pkgver" "$pkgdir/usr/bin/ra_lsp_server"
}