summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJay2021-05-23 14:49:33 +0100
committerJay2021-05-23 14:49:33 +0100
commit93c4ea6f68abe1251fc53819e91e03875bd8e942 (patch)
tree2b1f1328db32166161140441ebf304465956eb6c /PKGBUILD
parentf6b05a2dbd95e654ce69f357accc9f78e595d7d1 (diff)
downloadaur-93c4ea6f68abe1251fc53819e91e03875bd8e942.tar.gz
update to new sources (23-05-21)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0af75691d5ab..fe3ba64b3eeb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=rust-analyzer-nightly-bin
-pkgver=20210522
+pkgver=20210523
pkgrel=1
pkgdesc="An experimental Rust compiler front-end for IDEs (nightly)"
arch=('x86_64' 'i686')
@@ -10,14 +10,14 @@ makedepends=()
optdepends=()
provides=('rust-analyzer')
conflicts=('rust-analyzer')
-source=(https://github.com/rust-analyzer/rust-analyzer/releases/download/nightly/rust-analyzer-linux.gz)
+source=(rust-analyzer.gz::https://github.com/rust-analyzer/rust-analyzer/releases/download/nightly/rust-analyzer-x86_64-unknown-linux-gnu.gz)
sha256sums=('SKIP')
pkgver() {
- chmod a+x rust-analyzer-linux
- ./rust-analyzer-linux --version | cut -d' ' -f3 | sed 's/-//g'
+ chmod +x rust-analyzer
+ ./rust-analyzer --version | cut -d' ' -f3 | sed 's/-//g'
}
package() {
- install -D -m755 "$srcdir/rust-analyzer-linux" "$pkgdir/usr/bin/rust-analyzer"
+ install -D -m755 "$srcdir/rust-analyzer" "$pkgdir/usr/bin/rust-analyzer"
}