summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNick Shvelidze2017-09-22 10:38:00 +0400
committerNick Shvelidze2017-09-22 10:38:00 +0400
commitca92284693acf25af5a65e89399821bc0a21bf90 (patch)
treece1d2ca778501be6208f35f1a0bd922aa5d4d9b9 /PKGBUILD
downloadaur-rust-i586-git.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..97895933980f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Nick Shvelidze <captain@pirrate.me>
+pkgname=rust-i586-git
+pkgver=1.0.0.beta.r27179.g35edf7d8cb
+pkgrel=1
+pkgdesc="Rust for i586 machines without SSE2 (needs to be built on newer machines)"
+url="https://github.com/rust-lang/rust"
+arch=(i686 x86_64)
+license=('MIT')
+depends=(llvm-libs gcc-libs)
+makedepends=(python git)
+provides=(rust)
+conflicts=(rustup)
+source=("$pkgname::git://github.com/rust-lang/rust.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$pkgname"
+ ./configure --target=i586-unknown-linux-gnu --host=i586-unknown-linux-gnu --disable-jemalloc --prefix=/usr
+ python x.py build
+}
+
+package() {
+ cd "$pkgname"
+ python x.py dist
+ DESTDIR="$pkgdir/" python x.py install
+}