summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhaawda2017-05-28 18:40:36 +0200
committerhaawda2017-05-28 18:40:36 +0200
commitb5aee97c7196b0088943a09812d4f153a97308ca (patch)
treed8b177e8afa5b4598e859875c2f0ff2ef425b9a8 /PKGBUILD
parent0a428dc9b83f4188078fc73564cd3c37f9e164a8 (diff)
downloadaur-b5aee97c7196b0088943a09812d4f153a97308ca.tar.gz
disable compile docs again
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD66
1 files changed, 32 insertions, 34 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f4aeaac5bb92..63f6e0dc9cdf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgbase=rust-nightly
pkgname=('rust-nightly' 'rust-nightly-doc')
-pkgver=1.19.0.2017.05.12
+pkgver=1.19.0.2017.05.27
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc='A safe, concurrent, practical language'
@@ -11,10 +11,10 @@ url='http://www.rust-lang.org/'
license=('MIT' 'Apache')
makedepends=('libffi' 'perl' 'python2' 'curl' 'llvm')
source=("http://static.rust-lang.org/dist/rustc-nightly-src.tar.gz")
-options=('!makeflags' 'staticlibs' '!strip' '!emptydirs')
+md5sums=('390a6150bbc8c04c86529925a12a2126')
+options=('staticlibs' '!strip' '!emptydirs' '!makeflags')
conflicts=('rust')
provides=('rust')
-md5sums=('474daa139ad9f70f3d818eb2b93a2603')
build() {
cd rustc-nightly-src
@@ -25,47 +25,45 @@ build() {
--disable-codegen-tests \
--jemalloc-root=/usr/lib \
--disable-rpath \
- --enable-compiler-docs
+ --disable-compiler-docs
export RUSTFLAGS="$RUSTFLAGS -C link-args=-lffi"
-
- python2 ./x.py build --verbose
}
package_rust-nightly() {
- depends=('shared-mime-info')
- optdepends=('rust-doc-git: language and API documentation')
- provides=('rust')
- conflicts=('rust')
- cd rustc-nightly-src
+ depends=('shared-mime-info')
+ optdepends=('rust-doc-git: language and API documentation')
+ provides=('rust')
+ conflicts=('rust')
+ cd rustc-nightly-src
- make DESTDIR="$pkgdir" install
- rm -fr "$pkgdir"/usr/share/doc/rust/html
- rm "$pkgdir"/usr/share/doc/rust/README.md
- rm -f "$pkgdir"/usr/lib/rustlib/{components,manifest-rustc,manifest-rust-docs,rust-installer-version,install.log,uninstall.sh}
+ DESTDIR="$pkgdir" python2 ./x.py install
+ rm -fr "$pkgdir"/usr/share/doc/rust/html
+ rm "$pkgdir"/usr/share/doc/rust/README.md
+ rm -f "$pkgdir"/usr/lib/rustlib/{components,manifest-rustc,manifest-rust-docs,rust-installer-version,install.log,uninstall.sh}
- install -d "$pkgdir"/usr/share/licenses/rust-nightly/
- install -m644 COPYRIGHT LICENSE-* "$pkgdir"/usr/share/licenses/rust-nightly/
+ install -d "$pkgdir"/usr/share/licenses/rust-nightly/
+ install -m644 COPYRIGHT LICENSE-* "$pkgdir"/usr/share/licenses/rust-nightly/
}
package_rust-nightly-doc() {
- pkgdesc="A safe, concurrent, practical language from Mozilla. (Language and API documentation)"
- arch=('any')
- optdepends=('rust-nightly: to compile and run the programs you can write using this documentation')
- provides=('rust-doc')
- conflicts=('rust-doc')
+ pkgdesc="A safe, concurrent, practical language from Mozilla. (Language and API documentation)"
+ arch=('any')
+ optdepends=('rust-nightly: to compile and run the programs you can write using this documentation')
+ provides=('rust-doc')
+ conflicts=('rust-doc')
- cd rustc-nightly-src/src
- _docdir="$pkgdir"/usr/share/doc/rust
- install -d "$_docdir"
- cp -r doc/* "$_docdir"/ || true
+ cd rustc-nightly-src/src
+ _docdir="$pkgdir"/usr/share/doc/rust
+ install -d "$_docdir"
+ cp -r doc/* "$_docdir"/ || true
- chmod -R 644 "$_docdir"
- find "$_docdir" -type d -exec chmod 755 {} +
- for ext in aux out log toc; do
- rm -f "$_docdir"/*."$ext"
- done
- cd ..
- install -d "$pkgdir"/usr/share/licenses/rust-nightly-doc/
- install -m644 COPYRIGHT LICENSE-* "$pkgdir"/usr/share/licenses/rust-nightly-doc/
+ chmod -R 644 "$_docdir"
+ find "$_docdir" -type d -exec chmod 755 {} +
+ for ext in aux out log toc; do
+ rm -f "$_docdir"/*."$ext"
+ done
+ cd ..
+ install -d "$pkgdir"/usr/share/licenses/rust-nightly-doc/
+ install -m644 COPYRIGHT LICENSE-* "$pkgdir"/usr/share/licenses/rust-nightly-doc/
}