summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWenxuan Zhang2020-10-30 15:55:33 +0800
committerWenxuan Zhang2020-10-30 15:55:33 +0800
commit898de792dfe7c166ba9d6d1db14f1df51ef0c855 (patch)
tree28dd2a35b3319ad13c00c52c549db6771ba3a152 /PKGBUILD
downloadaur-898de792dfe7c166ba9d6d1db14f1df51ef0c855.tar.gz
init commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..68723e2800d3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Wenxuan Zhang <wenxuangm@gmail.com>
+_pkgname=rust-script
+pkgname=rust-script
+pkgver=0.7.0
+pkgrel=1
+pkgdesc="Run Rust files and expressions without any setup or compilation necessary."
+arch=(i686 x86_64)
+url='https://github.com/fornwall/rust-script'
+license=('MIT' 'APACHE')
+depends=()
+makedepends=('rust' 'cargo')
+conflicts=("rust-script-git" "rust-script-bin")
+provides=()
+
+source=("${url}/archive/v${pkgver}.tar.gz")
+md5sums=('9889f3143125df5ae4a31afa2b901f50')
+
+build() {
+ cd "$srcdir/${_pkgname}-${pkgver}"
+ cargo build --release --locked
+}
+
+package() {
+ cd "$srcdir/${_pkgname}-${pkgver}"
+ install -Dm755 "target/release/${_pkgname}" "$pkgdir/usr/bin/${_pkgname}"
+ install -Dm644 "README.md" "$pkgdir/usr/share/doc/${_pkgname}/README.md"
+ install -Dm644 "LICENSE-MIT" "$pkgdir/usr/share/licenses/${_pkgname}/LICENSE-MIT"
+ install -Dm644 "LICENSE-APACHE" "$pkgdir/usr/share/licenses/${_pkgname}/LICENSE-APACHE"
+}
+
+# vim:set noet sts=0 sw=4 ts=4 ft=PKGBUILD: