summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGuillaume Gauvrit2019-02-13 23:13:34 +0100
committerGuillaume Gauvrit2019-02-13 23:13:34 +0100
commit304cb665ec542f5dce702a5f4571f2de70c3c665 (patch)
treef94ae37567e4b2fc80e401923a15e9eaa939db9c /PKGBUILD
downloadaur-304cb665ec542f5dce702a5f4571f2de70c3c665.tar.gz
Initialize package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..943590c075b4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Guillaume Gauvrit <guillaume@gauvr.it>
+pkgname=rustaman-git
+pkgver=0.0.4af1e14
+pkgrel=1
+pkgdesc="Template based HTTP client"
+arch=('i686' 'x86_64')
+url="http://support.starleaf.com/downloads"
+license=('BSD')
+# depends=('libappindicator3' 'libnotify4')
+makedepends=('cargo' 'git')
+depends=('gtk3' 'gtksourceview3' 'openssl')
+options=('!emptydirs' '!strip')
+source=("$pkgname::git+https://github.com/mardiros/rustaman.git")
+sha1sums=('SKIP')
+
+
+
+build() {
+ cd "$pkgname"
+ cargo build --release
+}
+
+pkgver() {
+ cd "$pkgname"
+ #local tag=$(git tag --sort=-v:refname | grep '^[0-9]' | head -1)
+ local tag="0.0"
+ local commits_since=$(git rev-list $tag..HEAD --count)
+ echo "$tag.r$commits_since.$(git log --pretty=format:'%h' -n 1)"
+}
+
+package() {
+ cd "$pkgname"
+ install -Dm755 "target/release/rustaman" "$pkgdir/usr/bin/rustaman"
+
+ install -Dm644 "assets/rustaman-dark.xml" "$pkgdir/usr/share/rustaman/rustaman-dark.xml"
+ install -Dm644 "assets/rustaman-request.lang" "$pkgdir/usr/share/rustaman/rustaman-request.lang"
+ install -Dm644 "assets/rustaman-response.lang" "$pkgdir/usr/share/rustaman/rustaman-response.lang"
+}