summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChris Severance2023-05-24 21:57:31 -0400
committerChris Severance2023-05-24 21:57:31 -0400
commit31a5e5f1c795458e9dac955ba46014a9f446730e (patch)
treecd06818cfd37f3ef11824d340230ad547d43076e /PKGBUILD
parentb216a6a8a7350ff72f59208c0931c4fc4e0dbd2c (diff)
downloadaur-31a5e5f1c795458e9dac955ba46014a9f446730e.tar.gz
autu: Update to 1.2.0.r3437.gcb42edd7-1 Flutter 3.10.1, vcpkg aom, flutter_texture_render
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 18 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 723bd5ea424b..8ac929a16a22 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,7 +20,7 @@ _opt_FLUTTER=1
set -u
_pkgname='rustdesk'
pkgname="${_pkgname}-git"
-pkgver=1.2.0.r3233.g8e587352
+pkgver=1.2.0.r3437.gcb42edd7
pkgrel=1
pkgdesc='Yet another remote desktop software, written in Rust. Works out of the box, no configuration required. Great alternative to TeamViewer and AnyDesk!'
arch=('x86_64')
@@ -56,10 +56,10 @@ source+=("${_vcs[@]}")
if [ "${_opt_FLUTTER}" -eq 0 ]; then
source+=("https://raw.github.com/c-smile/sciter-sdk/master/bin.lnx/x64/libsciter-gtk.so")
else
- _FLUVER='3.7.0'
+ _FLUVER='3.10.1'
_FRBVER='1.75.0'
source+=(
- "https://storage.googleapis.com/flutter_infra_release/releases/stable/linux/flutter_linux_3.7.0-stable.tar.xz"
+ "https://storage.googleapis.com/flutter_infra_release/releases/stable/linux/flutter_linux_${_FLUVER}-stable.tar.xz"
"flutter_rust_bridge-${_FRBVER}.tar.gz::https://github.com/fzyzcjy/flutter_rust_bridge/archive/refs/tags/v${_FRBVER}.tar.gz"
#"flutter_rust_bridge-${_FRBVER}.tar.gz::https://pub.dev/packages/flutter_rust_bridge/versions/${_FRBVER}.tar.gz" # bad packaging
#"git+https://github.com/SoLongAndThanksForAllThePizza/flutter_rust_bridge.git"
@@ -71,7 +71,7 @@ md5sums=('SKIP'
'82e5e527336b41281a582204db1f3457'
'357dc26a802c34387512a42697846d16'
'10cf85debdd07be719a35ca3bfb8ea64'
- '9a844a9d6ec89c7da1e3027a5529411c'
+ 'fa8974848a1347828252aff068a7fe11'
'9cb4a6717db959e082db75200e75d3e1')
sha256sums=('SKIP'
'149e0cee002e59e0bb84543cf3cb099f108c08390392605e944daeb6594cbc29'
@@ -79,7 +79,7 @@ sha256sums=('SKIP'
'965e51c91ad9851e2337aebcc0f517440c637c506f3a03948062e3d5ea129a83'
'a78b05c0d8427a90eb5b4eb08af25309770c8379592bb0b8a863373128e6143f'
'f1acc15d0fd0cb431f4bf6eac32d5e932e40ea1186fe78e074254d6d003957bb'
- '51160abac1d0d82b45647be6b2a6ed2d3827d51c3920f2c8ebf3ea8cebe6f484'
+ 'e325dfc5621aaeecc95ce9c51d0f4adf15786cfe881ed619e96780a3ddfbbaf5'
'6efb71ac8086699da74dad6736c32ddb20db5dcabe167c49a8c3a650675eb84b')
_vcs=("${_vcs[@]%%::*}")
_vcs=("${_vcs[@]##*/}")
@@ -98,6 +98,8 @@ pkgver() {
set +u
}
+_vcpkg=(libvpx libyuv opus aom)
+
_prepare_vc() {
set -u
# rm -rf '/home/chris/.cache/vcpkg/archives'
@@ -118,6 +120,14 @@ _prepare_vc() {
false
fi
fi
+
+ local _vcpkgnew
+ _vcpkgnew="$(sed -E -n -e '/Linux.+: vcpkg / s:^.+install ::p' 'rustdesk/README.md')"
+ if [ "${_vcpkg[*]}" != "${_vcpkgnew}" ]; then
+ printf 'Flag package out of date: _vcpkg=(%s)\n' "${_vcpkgnew}"
+ set +u
+ false
+ fi
set +u
}
@@ -147,10 +157,8 @@ prepare() {
set -u
if [ "${_opt_FLUTTER}" -ne 0 ]; then
if [ ! -d 'flutter_rust_bridge' ]; then
- shopt -s failglob
ln -s "flutter_rust_bridge-${_FRBVER}" 'flutter_rust_bridge'
test -d 'flutter_rust_bridge'
- shopt -u failglob
fi
fi
cd "${_pkgname}"
@@ -197,7 +205,7 @@ build() {
if [ ! -x vcpkg/vcpkg ]; then
vcpkg/bootstrap-vcpkg.sh
fi
- nice vcpkg/vcpkg install libvpx libyuv opus
+ nice vcpkg/vcpkg install "${_vcpkg[@]}"
export VCPKG_ROOT="${PWD}/vcpkg"
cd "${_pkgname}"
@@ -220,13 +228,13 @@ build() {
export PATH="${srcdir}/flutter/bin:$PATH"
dart pub global activate ffigen --version 5.0.1
pushd "${srcdir}/flutter_rust_bridge/frb_codegen"; nice cargo install --path . ; popd
- pushd flutter ; flutter pub get ; popd
+ pushd flutter ; flutter clean; flutter pub get ; popd
~/.cargo/bin/flutter_rust_bridge_codegen --rust-input ./src/flutter_ffi.rs --dart-output ./flutter/lib/generated_bridge.dart
if [ "${_opt_BUILD_PY}" -ne 0 ]; then
nice ./build.py --hwcodec --flutter
else
git checkout src/ui/common.tis
- nice cargo build --features hwcodec,flutter --lib --release
+ nice cargo build --features hwcodec,flutter,flutter_texture_render --lib --release
#ain't there no more
#sed -i "s/ffi.NativeFunction<ffi.Bool Function(DartPort/ffi.NativeFunction<ffi.Uint8 Function(DartPort/g" flutter/lib/generated_bridge.dart
pushd flutter