summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexandre Bury2016-03-01 15:09:19 -0800
committerAlexandre Bury2016-03-01 15:09:19 -0800
commit18d3be0a21de78f3019807c9250a7acd25831609 (patch)
treefb88f8d4e2b8fee6c257eb25e55f90828ea9df30 /PKGBUILD
parentfe89c8e508dc2ce5effd76960e70ff37968655e4 (diff)
downloadaur-18d3be0a21de78f3019807c9250a7acd25831609.tar.gz
Update the install script
Create the license directory before coying files there
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fd133ae89b62..c4af0d83d27c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
-# Maintainer: Vlad M. <vlad@archlinux.net>
+# Maintainer: Alexandre B. <alexandre.bury@gmail.com>
+# Contributor: Vlad M. <vlad@archlinux.net>
pkgname=rusti-git
_pkgname=rusti
-pkgver=r121.13b5940
+pkgver=r164.9d77720
pkgrel=1
pkgdesc="REPL for Rust"
url="https://github.com/murarth/rusti"
@@ -27,6 +28,8 @@ build() {
}
package() {
- install -Dm755 "$srcdir/$_pkgname/target/release/$_pkgname" "$pkgdir/usr/bin/$_pkgname"
- install -Dm644 "$srcdir/$_pkgname/"{LICENSE-APACHE,LICENSE-MIT} "$pkgdir/usr/share/licenses/$pkgname/"
+ install -D -m755 "$srcdir/$_pkgname/target/release/$_pkgname" "$pkgdir/usr/bin/$_pkgname"
+ mkdir -p "$pkgdir/usr/share/licenses/$pkgname/"
+ install -D -m644 "$srcdir/$_pkgname/"{LICENSE-APACHE,LICENSE-MIT} "$pkgdir/usr/share/licenses/$pkgname/"
}
+