summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgithub-actions[bot]2023-11-11 22:05:51 +0000
committergithub-actions[bot]2023-11-11 22:05:51 +0000
commit0c753f816d3a68c37377d5555cd36d88cb1a2f06 (patch)
tree8447e70a8ddc1a382b91b31c34f504f96ea2cb49 /PKGBUILD
parent611825b5c78578acb65b5b5e5d32c8526a589fbe (diff)
downloadaur-0c753f816d3a68c37377d5555cd36d88cb1a2f06.tar.gz
Update PKGBUILD and .SRCINFO with GitHub Actions
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 16 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b36750f5d3c3..190a86a3b244 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,21 @@
# Maintainer: German Lashevich <german.lashevich@gmail.com>
-
-pkgver=0.4.1
-
-_binname=totp
-
+#
+# Source: https://github.com/zebradil/aur
+#
+# shellcheck disable=SC2034,SC2154
pkgname=rustotpony-bin
-_pkgname=${pkgname%-bin}
-pkgrel=1
-pkgdesc='RusTOTPony — CLI manager of one-time password generators like Google Authenticator'
-provides=(${_binname})
-conflicts=(${_pkgname})
+pkgver=0.4.1
+pkgrel=2
+pkgdesc="RusTOTPony — CLI manager of one-time password generators like Google Authenticator"
+url="https://github.com/zebradil/rustotpony"
arch=(x86_64)
-url="https://github.com/zebradil/${_pkgname}"
-license=('MIT')
-source=("${url}/releases/download/${pkgver}/${_binname}-linux")
+license=(MIT)
+conflicts=(rustotpony)
+provides=(totp)
+source=(rustotpony-bin-0.4.1::https://github.com/zebradil/rustotpony/releases/download/0.4.1/totp-linux)
sha256sums=('dcb96179a0748a96a44ab0e9b3da508825fe70acf457277d3aff5130335d9d35')
-
-package() {
- install -Dm755 "${srcdir}/${_binname}-linux" "${pkgdir}/usr/bin/${_binname}"
+package ()
+{
+ _binname=totp;
+ install -Dm755 "${srcdir}/${_binname}-linux" "${pkgdir}/usr/bin/${_binname}"
}