summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKelsey Maes2017-05-05 19:19:38 -0700
committerKelsey Maes2017-05-05 19:19:38 -0700
commitec1352c13b66858197a45b5bee58b24debadb3a3 (patch)
treec910aafb23f5d835874f017aa25edf398f509aa8 /PKGBUILD
downloadaur-ec1352c13b66858197a45b5bee58b24debadb3a3.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9f6d8e863004
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Kelsey Maes <kelseymaes at outlook dot com>
+
+pkgname=rustsym
+pkgver=0.3.1
+pkgrel=1
+pkgdesc="Tool to query symbols from rust code for use in IDEs"
+url="https://github.com/trixnz/rustsym"
+makedepends=('cargo')
+arch=('i686' 'x86_64')
+license=('MIT')
+source=("$pkgname-$pkgver.tar.gz::https://crates.io/api/v1/crates/$pkgname/$pkgver/download")
+sha256sums=('9ff315a51ca2ea8926ed6595b04f1fbf1bd4689ce0fc4dde75e8dbabf1d587f9')
+
+build() {
+ cd "$pkgname-$pkgver"
+ cargo build --release
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 target/release/rustsym "$pkgdir/usr/bin/rustsym"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE-MIT"
+}