summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormoparisthebest2019-01-10 00:30:15 -0500
committermoparisthebest2019-01-10 00:30:15 -0500
commit6f75c550ded47e73bdc789de805436f44791acd4 (patch)
treeb3206f1c2321e232e64492d20dcb9e97b90df522 /PKGBUILD
parentb82f3f3eb62ea9f517d54a8d0427b26978fd9d4c (diff)
downloadaur-6f75c550ded47e73bdc789de805436f44791acd4.tar.gz
cargo fetch in prepare()
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ab9fa53edf13..348ecf07159a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: moparisthebest <admin dot archlinux AT moparisthebest dot com>
pkgname=rusty-keys-git
-pkgver=0.0.2.r11.g99cf9c4
+pkgver=0.0.2.r18.g0ffc169
pkgrel=1
pkgdesc="uinput level keyboard mapper for linux"
url="https://code.moparisthebest.com/moparisthebest/rusty-keys"
@@ -21,6 +21,11 @@ pkgver() {
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd "$pkgname"
+ cargo fetch
+}
+
build() {
cd "$pkgname"
cargo build --release