summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormoparisthebest2017-11-16 00:54:21 -0500
committermoparisthebest2017-11-16 00:54:21 -0500
commitb82f3f3eb62ea9f517d54a8d0427b26978fd9d4c (patch)
treeb639ef51b93b1b70a7f0c5876999cbb3a7e9afcc /PKGBUILD
downloadaur-b82f3f3eb62ea9f517d54a8d0427b26978fd9d4c.tar.gz
First git version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ab9fa53edf13
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: moparisthebest <admin dot archlinux AT moparisthebest dot com>
+
+pkgname=rusty-keys-git
+pkgver=0.0.2.r11.g99cf9c4
+pkgrel=1
+pkgdesc="uinput level keyboard mapper for linux"
+url="https://code.moparisthebest.com/moparisthebest/rusty-keys"
+makedepends=('cargo' 'systemd' 'git')
+depends=('libsystemd')
+arch=('i686' 'x86_64' 'armv7h' 'armv6h')
+license=('AGPL')
+backup=('etc/rusty-keys/keymap.toml')
+source=("$pkgname::git+https://code.moparisthebest.com/moparisthebest/rusty-keys.git")
+validpgpkeys=('81F1C22DD41109D4A9C0A7B5B070F8D97D1A0BBA') # moparisthebest <admin AT moparisthebest.com>
+sha256sums=(SKIP)
+conflicts=(rusty-keys)
+provides=(rusty-keys=$pkgver)
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$pkgname"
+ cargo build --release
+}
+
+package() {
+ cd "$pkgname"
+ install -Dm644 systemd/rusty-keys.service "${pkgdir}/usr/lib/systemd/system/rusty-keys.service"
+ install -Dm755 target/release/rusty-keys "$pkgdir/usr/bin/rusty-keys"
+ install -Dm644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
+ install -Dm644 keymap.toml "${pkgdir}/etc/rusty-keys/keymap.toml"
+}