summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDennis Wölfing2018-04-15 22:08:14 +0200
committerDennis Wölfing2018-04-15 22:08:14 +0200
commit286727b8bb970ed747bba47aeff046dac2781a0f (patch)
tree89d31120b4ead7508d006c4b2beb58c55dbe5a9d /PKGBUILD
downloadaur-286727b8bb970ed747bba47aeff046dac2781a0f.tar.gz
rw 1.0-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4397689e5ba6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Dennis Wölfing <denniswoelfing at gmx dot de>
+
+pkgname=rw
+pkgver=1.0
+pkgrel=1
+pkgdesc="Blockwise input/output"
+arch=('x86_64')
+url="https://sortix.org/rw"
+license=('custom:ISC')
+depends=('glibc')
+makedepends=('git')
+_commit=755e3df0fab3c19d9c69c52dcb04687df8f587e2
+source=(git+https://gitlab.com/sortix/rw-portable.git#commit=$_commit)
+md5sums=('SKIP')
+
+build() {
+ cd rw-portable
+ make
+}
+
+package() {
+ cd rw-portable
+ make DESTDIR="$pkgdir" PREFIX=/usr install
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}