summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAles Katona2019-08-25 13:22:34 -0600
committerAles Katona2019-08-25 13:22:34 -0600
commit415eedfd6a6da2056d1fa76c45c03512dad72b89 (patch)
treec316eb2db2a55822e6d329608a9675a7687c2a4b /PKGBUILD
parente85e3a0d8c48bc02c87f11d20d5315c3353af7dc (diff)
downloadaur-415eedfd6a6da2056d1fa76c45c03512dad72b89.tar.gz
add desktop and icon
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c9b2122870b6..c1e7f1013c97 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Ales Katona <almindor@gmail.com>
pkgname=rx
pkgver=0.1.0
-pkgrel=1
+pkgrel=2
pkgdesc='A modern and extensible pixel editor implemented in rust.'
arch=(i686 x86_64)
url='http://cloudhead.io/rx/'
@@ -22,6 +22,10 @@ package() {
mkdir -p "${pkgdir}/usr/bin"
mkdir -p "${pkgdir}/usr/share/rx/palettes"
+ echo "$PWD"
+
install -Dm755 -t "${pkgdir}/usr/bin" "${srcdir}/${pkgname}-${pkgver}/target/release/rx"
install -Dm644 -t "${pkgdir}/usr/share/rx/palettes" "sweetie16.palette"
+ install -Dm644 -t "${pkgdir}/usr/share/applications" "../rx.desktop"
+ install -Dm644 -t "${pkgdir}/usr/share/pixmaps" "../rx.png"
}