aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFlorian Bruhin2016-01-28 11:27:52 +0100
committerFlorian Bruhin2016-01-28 11:27:52 +0100
commita3d7743392b56feb63fb87ee233778cfae953444 (patch)
treeb4af3efa7754c2354c0a4c3259cc5442c631dfcd /PKGBUILD
parent6e3e8e093eb5920792507f7a2ee4cfa912239c28 (diff)
downloadaur-a3d7743392b56feb63fb87ee233778cfae953444.tar.gz
cleanup, apply changes from [community]
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 26065c6e248b..6342dc0b477e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
_pkgname=rxvt-unicode
pkgname=rxvt-unicode-patched
pkgver=9.22
-pkgrel=1
+pkgrel=2
pkgdesc='Unicode enabled rxvt-clone terminal emulator (urxvt) with fixed font spacing'
arch=('i686' 'x86_64')
url='http://software.schmorp.de/pkg/rxvt-unicode.html'
@@ -32,14 +32,21 @@ sha1sums=('e575b869782fbfed955f84f48b204ec888d91ba1'
'b7fde1c46af45e831828738874f14b092b1e795f'
'dfbc8729c545105eff21e20ef3a4a3841a68a192')
-build() {
+prepare() {
cd $_pkgname-$pkgver
+
patch -p0 -i ../font-width-fix.patch
patch -p0 -i ../line-spacing-fix.patch
patch -p0 -i ../sgr-mouse-mode.patch
+}
+
+build() {
+ cd $_pkgname-$pkgver
+
+ # we disable smart-resize (FS#34807)
+ # do not specify --with-terminfo (FS#46424)
./configure \
--prefix=/usr \
- --with-terminfo=/usr/share/terminfo \
--enable-256-color \
--enable-combining \
--enable-fading \
@@ -54,7 +61,7 @@ build() {
--enable-rxvt-scroll \
--enable-selectionscrolling \
--enable-slipwheeling \
- --enable-smart-resize \
+ --disable-smart-resize \
--enable-startup-notification \
--enable-transparency \
--enable-unicode3 \