summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormrdotx2021-05-16 20:52:25 +0200
committermrdotx2021-05-16 20:52:25 +0200
commita14718eaceb662057aa3d636b2406e392a1e7074 (patch)
tree832876799eccf0f2a89d6eef31535d7222822baa /PKGBUILD
parent0243ece8b90ba561d926ccd6fdaa38b84e9a93ec (diff)
downloadaur-a14718eaceb662057aa3d636b2406e392a1e7074.tar.gz
update to 9.26
- 24-bit-color.patch rewritten to work with version 9.26 - removed perl-segfault.patch, included in 9.26 - removed sgr-mouse-mode.patch, included in 9.26
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD61
1 files changed, 36 insertions, 25 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a9716babbd58..77d6b77df341 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,57 +1,68 @@
# Maintainer: mrdotx <klassiker@gmx.de>
_pkgname=rxvt-unicode
pkgname=rxvt-unicode-truecolor-wide-glyphs
-pkgver=9.22
-pkgrel=4
-pkgdesc='Unicode enabled rxvt-clone terminal emulator (urxvt) with true color and enhanced glyphs support'
+pkgver=9.26
+pkgrel=1
+pkgdesc='Unicode enabled rxvt-clone terminal emulator (urxvt) with true color, enhanced glyphs and improved font rendering support'
arch=('i686' 'x86_64')
url='http://software.schmorp.de/pkg/rxvt-unicode.html'
license=('GPL')
-depends=('libxft' 'perl' 'startup-notification')
+depends=(
+ 'libxft'
+ 'libxt'
+ 'perl'
+ 'startup-notification'
+)
optdepends=('gtk2-perl: to use the urxvt-tabbed')
-provides=('rxvt-unicode' 'rxvt-unicode-terminfo' 'urxvt-resize-font' 'urxvt-keyboard-select')
-conflicts=('rxvt-unicode' 'rxvt-unicode-terminfo' 'urxvt-resize-font' 'urxvt-perls' 'urxvt-perls-git')
-source=(http://dist.schmorp.de/rxvt-unicode/$_pkgname-$pkgver.tar.bz2
+provides=(
+ 'rxvt-unicode'
+ 'rxvt-unicode-terminfo'
+ 'urxvt-resize-font'
+ 'urxvt-keyboard-select'
+)
+conflicts=(
+ 'rxvt-unicode'
+ 'rxvt-unicode-terminfo'
+ 'urxvt-resize-font'
+ 'urxvt-perls'
+ 'urxvt-perls-git'
+)
+source=(
+ http://dist.schmorp.de/rxvt-unicode/$_pkgname-$pkgver.tar.bz2
'urxvt.desktop'
'urxvtc.desktop'
'urxvt-tabbed.desktop'
'resize-font'
'keyboard-select'
- 'sgr-mouse-mode.patch'
'24-bit-color.patch'
'enable-wide-glyphs.patch'
'improve-font-rendering.patch'
- 'perl-segfault.patch'
- )
-sha1sums=('e575b869782fbfed955f84f48b204ec888d91ba1'
+)
+sha1sums=('d325d8cdea6bcb8e0b8b219b8451bf5c690b6c62'
'b5a4507f85ebb7bac589db2e07d9bc40106720d9'
'62c4ffecfce6967def394dd4d418b68652372ea2'
'cd204d608d114d39c80331efe0af0231ad6b7e18'
'a61366659c73bd551fa99a8415bb71e033897598'
'9883d0c31b45f8521829ea6a2041f2e9eb7abe6a'
- 'dfbc8729c545105eff21e20ef3a4a3841a68a192'
- '9f5db305863b17175e72f9e2d4a78d0d7f25fd34'
- 'd9f3b52b273d13fbd4089a7869ab2e70bf190bc9'
- '2f976cfbb4ae092d331e169b56ec6423b198f462'
- '361f4649596342d07311c2590b809b85b3a918ee')
+ '560097c0d6377461fcbe4c109f3113a6bcb38982'
+ 'c5ee4a50902d8c8d278938b080464a16d2c6af56'
+ '772b62071d73c0021adf334f037b95ef13d34317')
prepare() {
cd $_pkgname-$pkgver
- # https://aur.archlinux.org/packages/rxvt-unicode-patched
- patch -p0 -i ../sgr-mouse-mode.patch
-
- # https://aur.archlinux.org/packages/rxvt-unicode-truecolor
+ # The repo with original 24-bit-color.patch is no longer available:
+ # https://gist.githubusercontent.com/dan-santana/63271adf12171e0fc0bc/raw/70c6343d1c0b3bca0aba4f587ed501e6cbd98d00/24-bit-color.patch
+ # I have rewritten the patch to work with version 9.26.
+ # If someone has a better solution, please contact me!
patch -p0 -i ../24-bit-color.patch
+ # If you have problems with character rendering, try installing libxft-bgra from aur.
# https://aur.archlinux.org/packages/rxvt-unicode-cvs-patched-wideglyphs
- patch -p1 -i ../enable-wide-glyphs.patch
+ patch -p0 -i ../enable-wide-glyphs.patch
# https://aur.archlinux.org/packages/rxvt-unicode-improve-font-rendering
- patch -p1 -i ../improve-font-rendering.patch
-
- # https://bugs.archlinux.org/task/67691
- patch -p1 -i ../perl-segfault.patch
+ patch -p0 -i ../improve-font-rendering.patch
}
build() {