aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Wanner2019-05-22 13:51:39 +0200
committerDaniel Wanner2019-05-22 13:51:39 +0200
commit4beab19dae53bbd4ea223deee0f2dfe60d80303e (patch)
treefde643787dcac07e60025d645c215bc95a856d4f /PKGBUILD
parentc81bd93b5a52476ab42cf6bee2efca5eaa2f5b5f (diff)
downloadaur-4beab19dae53bbd4ea223deee0f2dfe60d80303e.tar.gz
Version bump. Fixed non-GUI build.
GUI build is currently broken, due to build config errors under Linux.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 11 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ebc87f96278e..8b71fdd76fa8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
# Maintainer: Daniel "dtubber" Wanner <daniel.wanner@tubber.xyz>
pkgname="ryzenadj-git"
-pkgver=v0.2.r3.g68bf3a1
-pkgrel=3
+pkgver=gui.v0.2.1.r2.g4656930
+pkgrel=1
pkgdesc="RyzenAdj tool for adjusting Ryzen Mobile power states"
url="https://github.com/FlyGoat/RyzenAdj"
arch=("x86_64")
+depends=("pciutils")
makedepends=("cmake")
license=("LGPL2")
source=("$pkgname::git+https://github.com/FlyGoat/RyzenAdj")
@@ -18,14 +19,16 @@ pkgver() {
build() {
cd $pkgname
- mkdir build
+ mkdir build || true
cd build
cmake ..
- make -j
+ make || true
}
package() {
- mkdir -p $pkgdir/usr/bin
- cp $pkgname/build/ryzenadj $pkgdir/usr/bin/
- chmod +x $pkgdir/usr/bin/ryzenadj
-} \ No newline at end of file
+ mkdir -p $pkgdir/usr/bin || true
+ cd $pkgname
+ pwd
+ ls -la
+ cp ryzenadj $pkgdir/usr/bin/
+}