summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatthias Mailänder2023-09-02 14:51:42 +0200
committerMatthias Mailänder2023-09-02 14:51:42 +0200
commit91ca80709968d4d55933d5d4b42cfd451cab32da (patch)
treeedc424a6a241a11e155eec7177a7a45d418e657a /PKGBUILD
parentb3e2a1b5335dc3afd31ee95c916df8e8e0300637 (diff)
downloadaur-s25rttr.tar.gz
Fix build with latest GCC.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9aa818179b40..e956b32b1172 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
#Maintainer: Matthias Mailänder <matthias at mailaender dot name>
#Contributor NiNjA <heinep at gmail dot com>
#Contributor float <flo.at at gmx dot de>
+#Contributor adlerweb <aur at adlerweb dot info>
pkgname=s25rttr
pkgver=0.9.5
-pkgrel=2
+pkgrel=3
pkgdesc="Return to the Roots is a reimplementation of Settlers II (Die Siedler II) by BlueByte Software GmbH. Put the files from the original game in the folder (/usr/share/s25rttr/S2/)"
arch=('i686' 'x86_64')
url="https://www.siedler25.org/"
@@ -12,13 +13,20 @@ license=('GPL3')
depends=('sdl2' 'sdl2_mixer' 'libcurl-gnutls' 'bzip2' 'glfw' 'libsamplerate' 'boost-libs' 'miniupnpc' 'lua51')
makedepends=('cmake' 'boost')
install="s25rttr.install"
-source=("$pkgname-$pkgver.tar.gz::https://github.com/Return-To-The-Roots/s25client/releases/download/v$pkgver/s25client_src_v$pkgver.tar.gz")
-sha256sums=('c6a9ef5b90943b5f2e81543f1e3290ff773663a45ebbbcc5a786bb5f5495fbec')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/Return-To-The-Roots/s25client/releases/download/v$pkgver/s25client_src_v$pkgver.tar.gz"
+ "s25rttr-gcc13.patch")
+sha256sums=('c6a9ef5b90943b5f2e81543f1e3290ff773663a45ebbbcc5a786bb5f5495fbec'
+ '66364841bf6e119e81117cf5aae75f4f84b7d9b16f7acd8edc63e8ecac9dde1e')
provides=("return-to-the-roots=${pkgver}")
conflicts=("return-to-the-roots")
+prepare() {
+ patch --forward --strip=1 --input="${srcdir}/s25rttr-gcc13.patch"
+}
+
build() {
cmake -B build -S "s25client_v$pkgver" \
+ -D CMAKE_CXX_FLAGS="-Wno-error=deprecated-declarations -Wno-dangling-reference" \
-D CMAKE_INSTALL_PREFIX=/usr \
-D RTTR_BUILD_UPDATER=OFF \
-D RTTR_USE_SYSTEM_LIBS=ON \