summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKevin Rauwolf2015-08-07 11:14:36 -0700
committerKevin Rauwolf2015-08-07 11:14:36 -0700
commit05b246655b9e92b06e0750fbb525f7ee8cf1bfce (patch)
treec311d38094509e40cdff06c941a2dc55cf668537 /PKGBUILD
downloadaur-s3-curl.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f72a079ac744
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Kevin Rauwolf <sweetpea@tentacle.net>
+pkgname=s3-curl
+pkgver=20120308
+pkgrel=1
+pkgdesc="Amazon S3 Authentication Tool for Curl"
+url="http://aws.amazon.com/code/128"
+arch=('x86_64' 'i686')
+license=('BSD')
+depends=('perl' 'perl-digest-hmac')
+optdepends=()
+makedepends=()
+conflicts=()
+replaces=()
+backup=()
+source=("http://s3.amazonaws.com/doc/s3-example-code/s3-curl.zip")
+md5sums=('f63d4ef54af0400dba7793b8f0793bd8')
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
+ install -Dm644 README "$pkgdir/usr/share/doc/$pkgname/README"
+ install -Dm755 s3curl.pl "$pkgdir/usr/bin/s3curl"
+}