summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRobert F. Nash2015-06-17 00:01:44 -0400
committerRobert F. Nash2015-06-17 00:01:44 -0400
commit9dcdbf571d954365f1b5918861612d2900f7bc24 (patch)
treed1faeebdb63a92a2433e9793f6c82d2c009e7b20 /PKGBUILD
downloadaur-s6-networking-musl.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3342637b2c7f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Lukas Braun <koomi+aur at hackerspace-bamberg dot de>
+pkgname=s6-networking-musl
+pkgver=2.1.0.0
+pkgrel=1
+pkgdesc="A suite of small networking utilities for Unix systems.."
+arch=('i686' 'x86_64')
+url="http://www.skarnet.org/software/s6-networking"
+license=('custom:ISC')
+makedepends=(musl 'skalibs-musl>=2.2.0.0' 's6-dns-musl>=2.0.0.2')
+depends=('execline-musl>=2.0.2.0' 's6-musl>=2.1.0.0')
+provides=('s6-networking=2.1.0.0')
+options=('staticlibs')
+changelog=CHANGELOG
+source=(${url}/s6-networking-$pkgver.tar.gz)
+sha256sums=('be75bddad884287c442900e10417c63980788ca1c5bae4188b64b375efba734d')
+
+build() {
+ cd "$srcdir/s6-networking-$pkgver"
+
+ unset CFLAGS
+ unset LDFLAGS
+ export CPPFLAGS='-nostdinc -isystem /usr/lib/musl/include -isystem /usr/include'
+ export CC='musl-gcc'
+ ./configure --enable-static-libc --bindir=/usr/bin
+ make
+}
+
+package() {
+ cd "$srcdir/s6-networking-$pkgver"
+
+ make DESTDIR="$pkgdir/" install
+ install -D -m644 COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}