summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMahdi Sarikhani2024-05-17 16:41:08 +0330
committerMahdi Sarikhani2024-05-17 16:41:08 +0330
commita7d62d2524553ccf9e919d376abb38626e0f7218 (patch)
tree488c4032a4df0fd3039454e85cd3f0d56645c901 /PKGBUILD
parentbc5029f3848903e7fe6f1a26f802f1398bbeea97 (diff)
downloadaur-a7d62d2524553ccf9e919d376abb38626e0f7218.tar.gz
v0.23.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 9 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9048144d4ab8..41cf1d6817f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Polarian <polarian@polarian.dev>
pkgname=saber
-pkgver=0.23.0
+pkgver=0.23.1
pkgrel=1
pkgdesc="The cross-platform notes app built for handwriting"
arch=('x86_64')
@@ -23,25 +23,24 @@ depends=('at-spi2-core'
makedepends=('clang' 'cmake' 'fvm' 'gst-plugins-base-libs' 'ninja')
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz"
"saber.sh")
-sha256sums=('9d5f6ec3d6a50420f86bdfb66e9a86c00707e768f102525647e8ffa1f3924058'
+sha256sums=('6e6a8e5d753b826baa72bf2bd792d5036142a1108916a21726bc5bccad7dafa5'
'2429585c739f6da2d2068fd44d5868bb9a0ef6657d8117ca32fd8e0b78942a10')
prepare() {
cd "${pkgname}-${pkgver}"
- fvm install stable
- fvm global stable
+ fvm install 3.19.6
+ fvm global 3.19.6
- # Disable analytics and enable linux desktop
- fvm flutter --no-version-check config --no-analytics
- fvm flutter --no-version-check config --enable-linux-desktop
+ # Disable analytics
+ fvm flutter --disable-analytics
# Pull dependencies within prepare, allowing for offline builds later on
- fvm flutter --no-version-check pub get
+ fvm flutter pub get
}
build() {
cd "${pkgname}-${pkgver}"
- fvm flutter --no-version-check build linux --release --prefixed-errors
+ fvm flutter build linux --release
}
package() {
@@ -49,7 +48,7 @@ package() {
# Install application, licence and desktop file (with assets)
install -d "${pkgdir}/opt/${pkgname}"
- cp -a --no-preserve=ownership build/linux/x64/release/bundle/* "${pkgdir}/opt/${pkgname}"
+ cp -r build/linux/x64/release/bundle/* "${pkgdir}/opt/${pkgname}"
install -Dm644 -t "${pkgdir}/usr/share/applications" flatpak/com.adilhanney.saber.desktop
install -Dm644 assets/icon/icon.png "${pkgdir}/usr/share/pixmaps/com.adilhanney.saber.png"