summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYamakaky2016-10-25 00:32:22 -0400
committerYamakaky2016-10-25 00:33:54 -0400
commitdde9773b820af61a537fd398ddc757f18aedfb74 (patch)
tree924be94431a820e02d4701ca4ca6badcf8275e1d /PKGBUILD
downloadaur-dde9773b820af61a537fd398ddc757f18aedfb74.tar.gz
1.0.6
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e8d929ea67b4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Yamakaky <yamakaky@yamaworld_fr>
+pkgname=safeeyes
+pkgver=1.0.6
+pkgrel=1
+pkgdesc="A Linux alternative for EyeLeo"
+arch=("any")
+url="https://github.com/slgobinath/SafeEyes"
+license=("GPL3")
+depends=("python2-xlib"
+ "hicolor-icon-theme"
+ "xorg-xprop"
+ "libappindicator-gtk3")
+source=("https://github.com/slgobinath/SafeEyes/releases/download/v$pkgver/safeeyes.tar.gz")
+sha1sums=('993c429afc9982b6acbd5a2d7e790488154e3fb7')
+
+package() {
+ mkdir -p "$pkgdir/usr/bin" "$pkgdir/usr/lib"
+ cp -r usr "$pkgdir/"
+ sed -ire "s/^Exec=.*$/Exec=safeeyes/" \
+ "$pkgdir/usr/share/applications/safeeyes.desktop"
+ cp -r opt/safeeyes/safeeyes "$pkgdir/usr/lib/"
+ ln -s /usr/lib/safeeyes/safeeyes "$pkgdir/usr/bin/"
+}