summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAntonio Rojas2020-01-05 19:58:45 +0000
committerAntonio Rojas2020-01-05 19:58:45 +0000
commit58e4d56b906177fd146aade27e823ad362b9cc2e (patch)
treeaea01be19d97b045cdab109fd05f42570d54478d /PKGBUILD
downloadaur-58e4d56b906177fd146aade27e823ad362b9cc2e.tar.gz
Initial upload
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..06ceebae9a74
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Antonio Rojas <arojas@archlinux.org>
+
+pkgname=sage-numerical-backends-gurobi
+pkgver=9.0b12
+pkgrel=1
+pkgdesc="Gurobi mixed integer linear programming backend for SageMath"
+arch=(x86_64)
+url="https://github.com/mkoeppe/sage-numerical-backends-gurobi"
+license=(GPL)
+depends=(sagemath gurobi)
+makedepends=(cython)
+source=($pkgname-$pkgver.tar.gz::"https://github.com/mkoeppe/$pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('2c1ca86a9460b605d6228dc68c753b102f39225bb096959ad0edbf01ef372d1f')
+
+build() {
+ cd $pkgname-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd $pkgname-$pkgver
+ python setup.py install --skip-build --root="$pkgdir" --optimize=1
+}