summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAntonio Rojas2016-08-12 22:03:46 +0200
committerAntonio Rojas2016-08-12 22:03:46 +0200
commitda625a82a5c0b5b9c9e7c78f1d1a1605a89ef641 (patch)
tree9fc91d7c4800dc6510835ffbcae6b6795a714e80 /PKGBUILD
parent8f6dc81303ee0e1555d47691c25db6119ba08d31 (diff)
downloadaur-da625a82a5c0b5b9c9e7c78f1d1a1605a89ef641.tar.gz
Sync with stable
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD66
1 files changed, 32 insertions, 34 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7a5d0734c614..ebd3dc55a2ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,44 +7,51 @@
# Special thanks to Nareto for moving the compile from the .install to the PKGBUILD
pkgname=sagemath-git
-pkgver=7.2.beta4.r0.g0aec256
+pkgver=7.4.beta0.r0.g0a80508
pkgrel=1
pkgdesc="Open Source Mathematics Software, free alternative to Magma, Maple, Mathematica, and Matlab"
arch=(i686 x86_64)
url="http://www.sagemath.org"
license=(GPL)
-depends=(ipython2 cysignals ppl mpfi palp brial singular cliquer maxima-ecl gfan sympow tachyon python2-rpy2 nauty
- python2-matplotlib python2-scipy python2-sympy python2-networkx python2-igraph libgap flintqs lcalc lrcalc lrs arb
- eclib gmp-ecm zn_poly gd python2-cvxopt pynac linbox gsl rubiks pari-galdata pari-seadata-small planarity rankwidth
+depends=(ipython2 cysignals ppl palp brial singular cliquer maxima-ecl gfan sympow tachyon python2-rpy2 nauty
+ python2-matplotlib python2-scipy python2-sympy python2-networkx python2-pillow libgap flintqs lcalc lrcalc arb
+ eclib gmp-ecm zn_poly gd python2-cvxopt pynac linbox rubiks pari-galdata pari-seadata-small planarity rankwidth
sage-data-combinatorial_designs sage-data-elliptic_curves sage-data-graphs sage-data-polytopes_db sage-data-conway_polynomials)
-optdepends=('cython2: to compile cython code' 'jmol: 3D plots' 'sage-notebook: Browser-based (flask) notebook interface'
+optdepends=('cython2: to compile cython code' 'python2-pkgconfig: to compile cython code'
+ 'jmol: 3D plots' 'sage-notebook: Browser-based (flask) notebook interface'
'sagemath-doc: Documentation and inline help' 'ipython2-notebook: Jupyter notebook interface' 'mathjax: Jupyter notebook interface'
'coin-or-cbc: COIN backend for numerical computations' 'coin-or-csdp: for computing Lovász theta-function of graphs'
'buckygen: for generating fullerene graphs' 'plantri: for generating some classes of graphs' 'benzene: for generating fusenes and benzenoids'
'modular_decomposition: modular decomposition of graphs' 'ffmpeg: to export animations to video' 'imagemagick: to show animations'
'coxeter3: Coxeter groups implementation' 'cryptominisat: SAT solver' 'gap-data: for computing Galois groups'
- 'jupyter-notebook: Jupyter notebook interface' 'atlas-lapack: improved performance for some linear algebra operations')
-makedepends=(cython2 boost ratpoints symmetrica fflas-ffpack python2-jinja coin-or-cbc
+ 'lrs: Algorithms for linear reverse search used in game theory and for computing volume of polytopes'
+ 'libhomfly: for computing the homfly polynomial of links' 'libbraiding: for computing in braid groups'
+ 'python2-igraph: igraph backend for graph theory' 'sage-notebook-exporter: convert flask notebooks to jupyter'
+ 'jupyter-notebook: Jupyter notebook interface')
+makedepends=(cython2 boost ratpoints symmetrica fflas-ffpack python2-jinja coin-or-cbc libhomfly libbraiding
mcqd coxeter3 cryptominisat modular_decomposition bliss-graphs tdlib python2-pkgconfig meataxe) # libfes
conflicts=(sagemath)
provides=(sagemath sage-mathematics)
source=("git://git.sagemath.org/sage.git#branch=develop"
- pexpect.zip::"https://github.com/pexpect/pexpect/archive/524495960dd8898ddd30f7ba37298de51beee773.zip"
- anal.h package.patch env.patch paths.patch clean.patch skip-check.patch cython-sys-path.patch
- disable-fes.patch jupyter-path.patch test-optional.patch python-2.7.11.patch)
+ anal.h env.patch paths.patch clean.patch skip-check.patch cython-sys-path.patch is-package-installed.patch package.patch
+ disable-fes.patch jupyter-path.patch test-optional.patch python-2.7.11.patch linbox-1.4.patch ecm-7.patch
+ increase-rtol.patch)
md5sums=('SKIP'
- 'a346bb2c0350c1cb17d5325235c5e38a'
'a906a180d198186a39820b0a2f9a9c63'
- '9ba81f717ffd4e20b8b2f2a318307488'
- 'f6c62f0ccc168c5e6e3dd9d6f73f6389'
- '0f746ed394fd7eb7a6b3963014976098'
+ 'd4d3c235c99b2bc92dde9f6e53935a8d'
+ '45b84ae5579273196df44f7464a01a30'
'6d9ae0978ce6a05a0da2cafdfb178a09'
- '5947a420a0b1483f0cbc74c76895789b'
+ '6cafcb381437d4751fd55b25d5090987'
'a1bcdd3fe620dbae60ed8b0e98b2ece7'
+ 'c1494f51d93c9c7ffc17d5e015fe480d'
+ '9ba81f717ffd4e20b8b2f2a318307488'
'4eb23a3c7363258bc9ba764d6e5512ba'
'16b529194c6105c3364127bd8f1efa83'
'cdcabd475b80afe0534a5621e972736e'
- 'ef927896f2071b442b1d07d7e69f5f3a')
+ 'ef927896f2071b442b1d07d7e69f5f3a'
+ 'a276f0fbbff6eade409d0569ebd728d4'
+ '0c9a57d35de80c2cd418ebec912efbbb'
+ '39d3fded716d2a7ae0ab03e0896b7497')
pkgver() {
cd sage
@@ -72,11 +79,6 @@ prepare(){
patch -p0 -i ../skip-check.patch
# supress warning about GAP install dir
sed -e "s|gapdir = os.path.join(SAGE_LOCAL, 'gap', 'latest')|gapdir = '/usr/lib/gap'|" -i src/sage/libs/gap/util.pyx
-# fix Cremona database detection
- sed -e "s|is_package_installed('database_cremona_ellcurve')|os.path.exists('/usr/share/sage/cremona/cremona.db')|" \
- -i src/sage/databases/cremona.py
-# find bliss headers
- sed -e 's|graph.hh|bliss/graph.hh|' -i src/sage/graphs/bliss.pyx
# don't list optional packages when running tests
patch -p0 -i ../test-optional.patch
# set jupyter path
@@ -85,12 +87,20 @@ prepare(){
patch -p0 -i ../python-2.7.11.patch
# search system paths for cython includes
patch -p1 -i ../cython-sys-path.patch
+# fix regressions with ECM 7
+ patch -p1 -i ../ecm-7.patch
+# increase numerical tolerance, needed by scipy 0.18
+ patch -p1 -i ../increase-rtol.patch
# Upstream patches
# fix build against libfes 0.2 http://trac.sagemath.org/ticket/15209
# patch -p0 -i ../fes02.patch
# disable fes module, fails to compile
- patch -p0 -i ../disable-fes.patch
+ patch -p0 -i ../disable-fes.patch
+# port to new givaro/fflas-ffpack/linbox http://trac.sagemath.org/ticket/17635
+ patch -p1 -i ../linbox-1.4.patch
+# replace is_package_installed usage http://trac.sagemath.org/ticket/20377
+ patch -p1 -i ../is-package-installed.patch
# use python2
sed -e 's|#!/usr/bin/env python|#!/usr/bin/env python2|' -e 's|exec python|exec python2|' -i src/bin/*
@@ -102,9 +112,6 @@ prepare(){
# copy required private PARI header
mkdir -p src/pari
cp "$srcdir"/anal.h src/pari/anal.h
-
-# remove developer interface
- rm -r src/sage/dev
}
build() {
@@ -118,9 +125,6 @@ build() {
make sage/ext/interpreters/__init__.py
python2 setup.py build
-
- cd "$srcdir"/pexpect-*
- python2 setup.py build
}
package() {
@@ -152,10 +156,4 @@ package() {
# Remove sage_setup
rm -r "$pkgdir"/usr/lib/python2.7/site-packages/sage_setup
-
-# install pexpect
- cd "$srcdir"/pexpect-*
- python2 setup.py install --root="$pkgdir" --optimize=1
- mkdir -p "$pkgdir"/usr/lib/sage/site-packages/
- mv "$pkgdir"/usr/lib/python2.7/site-packages/pexpect "$pkgdir"/usr/lib/sage/site-packages/
}