summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAntonio Rojas2021-05-11 18:46:00 +0200
committerAntonio Rojas2021-05-11 18:46:00 +0200
commitddb57898be299052eb7971a8ded148749e414cdc (patch)
treefbe45712c435397a3d013a0b38234800bd25cd6a /PKGBUILD
parent0ebcb979ea76a6c57cdfd0f958a27b9c53e0b5ab (diff)
downloadaur-ddb57898be299052eb7971a8ded148749e414cdc.tar.gz
Sync with stable
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD56
1 files changed, 24 insertions, 32 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4dca55f08553..50b64ace3621 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,21 +5,21 @@
# Contributor: Osman Ugus <ugus11 at yahoo dot com>
# Contributor: Stefan Husmann <stefan-husmann at t-online dot de>
-pkgbase=sagemath-git
-pkgname=(sagemath-git sagemath-jupyter-git)
-pkgver=9.3.rc0.r0.g2c25f07cfd
+pkgname=sagemath-git
+pkgver=9.3.r0.gd6c5cd9be7
pkgrel=1
-pkgdesc="Open Source Mathematics Software, free alternative to Magma, Maple, Mathematica, and Matlab"
+pkgdesc='Open Source Mathematics Software, free alternative to Magma, Maple, Mathematica, and Matlab'
arch=(x86_64)
-url="http://www.sagemath.org"
+url='http://www.sagemath.org'
license=(GPL)
depends=(ipython palp brial cliquer maxima-ecl gfan sympow nauty python-rpy2 python-fpylll python-psutil python-cypari2
- python-matplotlib python-scipy python-sympy python-networkx python-pillow python-pplpy python-sphinx
+ python-matplotlib python-scipy python-sympy python-networkx python-pillow python-pplpy python-sphinx python-ipywidgets
gap flintqs lcalc lrcalc arb eclib zn_poly gd python-cvxopt pynac linbox m4rie pari-galdata pari-seadata-small planarity rankwidth tachyon
sage-data-combinatorial_designs sage-data-elliptic_curves sage-data-graphs sage-data-polytopes_db sage-data-conway_polynomials
- iml libgiac libhomfly libbraiding symmetrica threejs-sage)
+ iml giac libhomfly libbraiding symmetrica threejs-sage)
optdepends=('cython: to compile cython code' 'python-pkgconfig: to compile cython code'
- 'jmol: alternative 3D plot engine' 'sagemath-doc: HTML documentation' 'python-igraph: igraph backend for graph theory'
+ 'jmol: alternative 3D plot engine' 'jupyter-jsmol: alternative 3D plot engine in the Jupyter notebook'
+ 'sagemath-doc: HTML documentation' 'python-igraph: igraph backend for graph theory'
'sage-numerical-backends-coin: COIN mixed integer linear programming backend'
'sage-numerical-backends-gurobi: Gurobi mixed integer linear programming backend'
'coin-or-csdp: for computing Lovász theta-function of graphs'
@@ -33,22 +33,26 @@ optdepends=('cython: to compile cython code' 'python-pkgconfig: to compile cytho
'shared_meataxe: faster matrix arithmetic over finite fields' 'openblas: faster linear algebra'
'sirocco: for computing the fundamental group of the complement of a plane curve' 'primecount: faster prime_pi implementation'
'dot2tex: for displaying some diagrams' 'cryptominisat5: SAT solver' 'python-pycosat: picosat SAT solver'
- 'python-pip: to install optional packages with sage -pip')
+ 'python-pip: to install optional packages with sage -pip' 'sage-notebook-exporter: convert flask notebooks to Jupyter')
makedepends=(cython boost ratpoints python-jinja sirocco mcqd coxeter bliss tdlib python-pkgconfig shared_meataxe primecount git)
+conflicts=(sagemath)
+provides=(sagemath)
source=(git://git.sagemath.org/sage.git#branch=develop
sagemath-optional-packages.patch
latte-count.patch
test-optional.patch
sagemath-pari-2.13.patch
sagemath-lrcalc2.patch
- sagemath-eclib-20210310.patch)
+ sagemath-eclib-20210310.patch
+ sagemath-matplotlib-3.4.patch)
sha256sums=('SKIP'
- '4fdf318ec9a54567877b93af8c668ad925f2a82370048db158d134b58b064204'
- 'af922e1f978821a9a1f6c9a56130d71e5011c84a7aee7bf66a591bee658af30b'
- '7da0dbcda15a327c21dc33853cb8f98cb86a283139f8735e3b20a71d49458a88'
- '33907a0681900b9580b8aa5b3d2ddb2d609977076c38fdbc47279ecef4104ed1'
+ 'c100a61c8dfade43bebc622a363abcb3d935a2f40958371ad87a9eb00689f8b0'
+ '88e944f23c3b2391dc2e9f9be8e1131152d837dc8c829dfc714663869a272e81'
+ 'af984186f852d2847d770a18fb6822296c50a652dbf55a1ed59d27517c3d3ee4'
+ '32d586609dd6970f103574f75287bb641eb0a93618e84a1f671a2816e9420012'
'240ac4c29d96d56407a20e1b7f9846e342a7eb2bb4edd6e5c86b3b5a8ff462f9'
- 'e7b31f5e7ea88681c6eda41e5a74a2859a12dd128e75c00db3cfbd1d8ddf080d')
+ 'e7b31f5e7ea88681c6eda41e5a74a2859a12dd128e75c00db3cfbd1d8ddf080d'
+ '5e6f919a386e1a9e9caf7528088a3a3f3f3fc51b158a4daf435771afb1212384')
pkgver() {
cd sage
@@ -65,6 +69,8 @@ prepare(){
patch -p1 -i ../sagemath-lrcalc2.patch
# Fix build with eclib 20210310 https://trac.sagemath.org/ticket/31443
patch -p1 -i ../sagemath-eclib-20210310.patch
+# Fix deprecation warnings with matplotlib 3.4 https://trac.sagemath.org/ticket/31580
+ patch -p1 -i ../sagemath-matplotlib-3.4.patch
# Arch-specific patches
# assume all optional packages are installed
@@ -82,31 +88,17 @@ build() {
python setup.py build
}
-package_sagemath-git() {
- optdepends+=('sagemath-jupyter-git: Jupyter kernel')
- conflicts=(sagemath)
- provides=(sagemath)
-
+package() {
cd sage/build/pkgs/sagelib/src
+
python setup.py install --root="$pkgdir" --optimize=1
# Remove sage_setup
rm -r "$pkgdir"/usr/lib/python*/site-packages/sage_setup
-# Split jupyter kernel
- rm -r "$pkgdir"/usr/share
-}
-
-package_sagemath-jupyter-git() {
- pkgdesc='Jupyter kernel for SageMath'
- depends=(sagemath python-jupyter_client python-ipywidgets jupyter-jsmol)
- optdepends=('sage-notebook-exporter: convert flask notebooks to Jupyter')
-
- cd sage/src
- python -c "from sage.repl.ipython_kernel.install import SageKernelSpec; SageKernelSpec.update(prefix='$pkgdir/usr')"
# fix symlinks to assets
_pythonpath=`python -c "from sysconfig import get_path; print(get_path('platlib'))"`
- for _i in $(ls sage/ext_data/notebook-ipython); do
+ for _i in $(ls "$srcdir"/sage-$pkgver/src/sage/ext_data/notebook-ipython); do
rm "$pkgdir"/usr/share/jupyter/kernels/sagemath/$_i
ln -s $_pythonpath/sage/ext_data/notebook-ipython/$_i "$pkgdir"/usr/share/jupyter/kernels/sagemath/
done