summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAntonio Rojas2017-02-02 22:52:42 +0000
committerAntonio Rojas2017-02-02 22:52:42 +0000
commitec38ec109f4c0e8564723ce46b98beca97289e82 (patch)
treedb15ca1094627f97ae081355f1eaa9f27e31ea3e /PKGBUILD
parent9a8c7db9ba67e03fbb728f3168cc0de70f9e875c (diff)
downloadaur-ec38ec109f4c0e8564723ce46b98beca97289e82.tar.gz
Update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 13 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 779e6c0d3e03..7567b325e12e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,13 +8,13 @@
pkgbase=sagemath-git
pkgname=(sagemath-git sagemath-jupyter-git)
-pkgver=7.6.beta0.r0.gd92d7c01f4
+pkgver=7.6.beta2.r0.g375d4ee776
pkgrel=1
pkgdesc="Open Source Mathematics Software, free alternative to Magma, Maple, Mathematica, and Matlab"
arch=(i686 x86_64)
url="http://www.sagemath.org"
license=(GPL)
-depends=(ipython2 ppl palp brial cliquer maxima-ecl gfan sympow tachyon nauty python2-rpy2 python2-fpylll python2-psutil
+depends=(ipython2 ppl palp brial cliquer maxima-ecl gfan sympow nauty python2-rpy2 python2-fpylll python2-psutil
python2-matplotlib python2-scipy python2-sympy python2-networkx python2-pillow python2-future libgap flintqs lcalc lrcalc arb
eclib gmp-ecm zn_poly gd python2-cvxopt pynac linbox rubiks pari-galdata pari-seadata-small planarity rankwidth
sage-data-combinatorial_designs sage-data-elliptic_curves sage-data-graphs sage-data-polytopes_db sage-data-conway_polynomials)
@@ -27,24 +27,27 @@ optdepends=('cython2: to compile cython code' 'python2-pkgconfig: to compile cyt
'coxeter3: Coxeter groups implementation' 'cryptominisat2: SAT solver' 'gap-data: for computing Galois groups'
'lrs: Algorithms for linear reverse search used in game theory and for computing volume of polytopes'
'libhomfly: for computing the homfly polynomial of links' 'libbraiding: for computing in braid groups'
- 'python2-pynormaliz: Normaliz backend for polyhedral computations')
+ 'libfes: exhaustive search of solutions for boolean equations' 'python2-pynormaliz: Normaliz backend for polyhedral computations'
+ 'three.js: alternative 3D plots engine' 'tachyon: alternative 3D plots engine')
makedepends=(cython2 boost ratpoints symmetrica python2-jinja coin-or-cbc libhomfly libbraiding
mcqd coxeter3 cryptominisat2 modular_decomposition bliss-graphs tdlib python2-pkgconfig meataxe git) # libfes
source=("git://git.sagemath.org/sage.git#branch=develop"
- env.patch skip-check.patch cython-sys-path.patch is-package-installed.patch package.patch disable-fes.patch
- jupyter-path.patch test-optional.patch ecm-7.patch increase-rtol.patch r-no-readline.patch)
+ env.patch skip-check.patch cython-sys-path.patch is-package-installed.patch package.patch
+ jupyter-path.patch test-optional.patch ecm-7.patch increase-rtol.patch r-no-readline.patch
+ sagemath-planarity3.patch fes02.patch)
sha256sums=('SKIP'
'9dba04ff13626a7b6c338a8b18a6c27d343f68a547a218533cf773af3dae6635'
'178074c0a22da4a8129ec299a6845aaae8cf3ef1da6f62b34f2ec0ed50c1e6a2'
'ff7e034d08ab084fdb193484f7fe3a659ebcd8ab33a2b7177237d65b26de7872'
'd60fb0fbd27991ce9496ca035a54b03334b5b53f244227a8d6e13f3327ce75d2'
'4a2297e4d9d28f0b3a1f58e1b463e332affcb109eafde44837b1657e309c8212'
- 'c9e2bfa91baf155cce1bee09c11b0214c20c38e4fc9f5e2d090da86564110327'
'889b65598d2a15e73eb482f543ec9b28d8992eeb57b07883c2e9627dfee15a9b'
'81d08c6a760f171f3381455b66a6c84789c9f0eefddbe6ca5794075514ad8c3a'
'06bc1e5b409e21d49fc71ef03e96ec35b7a9b524bfd1f81a2dbf5c64a55e5acf'
'1c068c524a2926ba222b36b0f4229a45c6f00c2225ffde0b0555e4e9659342d5'
- 'ef9f401fa84fe1772af9efee6816643534f2896da4c23b809937b19771bdfbbf')
+ 'ef9f401fa84fe1772af9efee6816643534f2896da4c23b809937b19771bdfbbf'
+ 'a1c562ebe4538d672404ca3ac2e954a3c955afeb7463f7b4fe6eaa6fa74fe5c7'
+ 'a39da083c038ada797ffc5bedc9ba47455a3f77057d42f86484ae877ef9172ea')
pkgver() {
cd sage
@@ -73,12 +76,12 @@ prepare(){
patch -p1 -i ../increase-rtol.patch
# fix freezes in R interface with readline 7 (Debian)
patch -p1 -i ../r-no-readline.patch
+# fix build with planarity 3 (Debian)
+ patch -p2 -i ../sagemath-planarity3.patch
# Upstream patches
# fix build against libfes 0.2 http://trac.sagemath.org/ticket/15209
-# patch -p0 -i ../fes02.patch
-# disable fes module, fails to compile
- patch -p0 -i ../disable-fes.patch
+ patch -p1 -i ../fes02.patch
# replace is_package_installed usage http://trac.sagemath.org/ticket/20377
patch -p1 -i ../is-package-installed.patch