summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2017-01-21 21:43:19 +0330
committerMohammadreza Abdollahzadeh2017-01-21 21:43:19 +0330
commit6ae29217e0f256890eb724c0e75840616040c636 (patch)
treec5901810cfe48b1e6c19488e855f546f331f9598 /PKGBUILD
downloadaur-6ae29217e0f256890eb724c0e75840616040c636.tar.gz
Initial Import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a093cedcbc2c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# $Id$
+# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
+
+pkgname=sahel-fonts
+pkgver=1.0.0_alpha8
+pkgrel=1
+pkgdesc="A beautiful Persian font."
+url="https://rastikerdar.github.io/sahel-font/"
+arch=(any)
+license=('OFL')
+depends=('fontconfig')
+provides=('ttf-sahel' "$pkgname")
+conflicts=('ttf-sahel' "$pkgname")
+replaces=('ttf-sahel')
+source=("$pkgname-$pkgver.zip::https://github.com/rastikerdar/sahel-font/releases/download/v${pkgver//_/-}/sahel-font-v${pkgver//_/-}.zip")
+sha256sums=('f34a30e1c9055eb410dbcef995bc4e3f9d86bf6ca10406e3b1ebba18d9f8c951')
+
+package() {
+ install -d "$pkgdir/usr/share/fonts/${pkgname%-fonts}"
+ install -t "$pkgdir/usr/share/fonts/${pkgname%-fonts}" -m644 ./Sahel*.{eot,ttf,woff}
+ install -t "$pkgdir/usr/share/fonts/${pkgname%-fonts}" -m644 ./{Farsi*,Without-Latin}/Sahel*.{eot,ttf,woff}
+ install -Dm644 ./LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: