summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzxp198210052024-03-21 15:44:40 +0800
committerzxp198210052024-03-21 15:44:40 +0800
commit91c128ca75f74d40311b148fe5a29e0cc67bd962 (patch)
treed57e7afadfff1efb7b32b20d60e873e35727b0aa /PKGBUILD
parent4742845d493010716864e6bc3d3ee9f33f62607f (diff)
downloadaur-salesforce2sql-bin.tar.gz
fix errors
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7e54ecf8f9ff..b4807739aa77 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=salesforce2sql-bin
pkgver=0.10.0
_electronversion=28
-pkgrel=2
+pkgrel=3
pkgdesc="Electron app to convert a Salesforce org's schema into a similarly shaped database."
arch=('x86_64')
url="https://github.com/acrosman/Salesforce2Sql"
@@ -11,7 +11,7 @@ provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
"electron${_electronversion}"
- 'python'
+ 'python>3'
'python-setuptools'
'nodejs'
)
@@ -23,11 +23,12 @@ source=(
"${pkgname%-bin}.sh"
)
sha256sums=('5abdb9dfc1c43bb2fa6cc6e11bc98d049051d7589d3fe123d3184284fc9ccf49'
- '50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe')
+ 'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|app|g" \
+ -e "s|@options@||g" \
-i "${srcdir}/${pkgname%-bin}.sh"
}
package() {