summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKevin MacMartin2016-05-30 22:27:40 -0400
committerKevin MacMartin2016-05-30 22:27:40 -0400
commit5760be9092ce5024babe9535a693cbff9c0affd7 (patch)
treeaefb5e8a9452837e775704de1e8b6ed5170353fb /PKGBUILD
parent0076113b0c7644769c48f793d67a681202a1a8a3 (diff)
downloadaur-5760be9092ce5024babe9535a693cbff9c0affd7.tar.gz
Update the source to a mirror of the original repo, use the included LICENSE, clean up the package and include a .gitignore
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 15 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3b5e44b79d70..00e422562e15 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,32 @@
-# Maintainer: Kevin MacMartin <prurigro at gmail dot com>
+# Maintainer: Kevin MacMartin <prurigro@gmail.com>
_pkgname=salsapipe
pkgname=${_pkgname}-git
pkgver=20150727.r26.6d81ace
-pkgrel=1
-pkgdesc="Encrypted network tunneling using salsa20 from libnettle and GPG from libgpgme"
-url="https://github.com/0xcaca0/${_pkgname}"
+pkgrel=2
+pkgdesc='Encrypted network tunneling using salsa20 from libnettle and GPG from libgpgme'
+url='https://github.com/prurigro/salsapipe'
license=('GPL3')
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
groups=('archassault' 'archassault-networking')
-depends=('gpgme' 'nettle')
+depends=('gpgme')
makedepends=('git')
-
-source=("git://github.com/0xcaca0/${_pkgname}.git#branch=master"
- "LICENSE")
-sha512sums=('SKIP' '98cb62428d5dd50917a5ce69ad4e7508b5447b1aba83080e2d870f3b410db3747d0ff31b142b9d1c3b8dab10fba028fb78962b23d02cd47352bc2f2cd7dd8620')
+source=("git+$url")
+sha512sums=('SKIP')
pkgver() {
- cd $_pkgname
- printf "%s.r%s.%s" "$(git show -s --format=%ci master | sed 's/\ .*//g;s/-//g')" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd $_pkgname
+ printf "%s.r%s.%s" "$(git show -s --format=%ci master | sed 's/\ .*//g;s/-//g')" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd $_pkgname
- make
+ cd $_pkgname
+ make
}
package() {
- install -Dm755 ${_pkgname}/salsamsg "${pkgdir}/usr/bin/salsamsg"
- install -Dm644 ${_pkgname}/salsamsg.1 "${pkgdir}/usr/share/man/man1/salsamsg.1"
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+ cd $_pkgname
+ install -Dm755 salsamsg "$pkgdir/usr/bin/salsamsg"
+ install -Dm644 salsamsg.1 "$pkgdir/usr/share/man/man1/salsamsg.1"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
}