summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKevin MacMartin2015-06-10 00:37:49 -0400
committerKevin MacMartin2015-06-10 00:37:49 -0400
commitf4045b26389f8beabc88953d6afb98e707e6898f (patch)
tree2b759178c2b501bb46e0d2261328bcd7bd2750e6 /PKGBUILD
downloadaur-f4045b26389f8beabc88953d6afb98e707e6898f.tar.gz
Initial import into AUR 4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9243ad4512b7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Kevin MacMartin <prurigro at gmail dot com>
+
+_pkgname=salsapipe
+pkgname=${_pkgname}-git
+pkgver=20140730.r25.51c5c6b
+pkgrel=1
+pkgdesc="Encrypted network tunneling using salsa20 from libnettle and GPG from libgpgme"
+url="https://github.com/0xcaca0/${_pkgname}"
+license=('GPL3')
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+groups=('archassault' 'archassault-networking')
+depends=('gpgme' 'nettle')
+makedepends=('git')
+
+source=("git://github.com/0xcaca0/${_pkgname}.git#branch=master"
+ "LICENSE")
+sha512sums=('SKIP' '98cb62428d5dd50917a5ce69ad4e7508b5447b1aba83080e2d870f3b410db3747d0ff31b142b9d1c3b8dab10fba028fb78962b23d02cd47352bc2f2cd7dd8620')
+
+pkgver() {
+ cd $_pkgname
+ printf "%s.r%s.%s" "$(git show -s --format=%ci master | sed 's/\ .*//g;s/-//g')" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd $_pkgname
+ make
+}
+
+package() {
+ install -Dm755 ${_pkgname}/salsamsg "${pkgdir}/usr/bin/salsamsg"
+ install -Dm644 ${_pkgname}/salsamsg.1 "${pkgdir}/usr/share/man/man1/salsamsg.1"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+}