summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBrad Erhart2020-02-19 03:33:05 -0800
committerBrad Erhart2020-02-19 03:33:05 -0800
commiteaaad1a3ece7249170c6bc33f5eaa1eb47e8f1e8 (patch)
tree4b1abe843b51da67ac5fc2743ae873e398005977 /PKGBUILD
downloadaur-eaaad1a3ece7249170c6bc33f5eaa1eb47e8f1e8.tar.gz
Creating package for saml2aws v2.23.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..92e49b40e8e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Brad Erhart <brae dot 04 plus aur at gmail dot com>
+
+pkgname=saml2aws-bin
+_pkgname="${pkgname%-bin}"
+pkgver=2.23.0
+pkgrel=1
+pkgdesc='CLI tool to login and retrieve AWS temporary credentials using a SAML IDP'
+arch=('x86_64')
+_goos='linux'
+_goarch='amd64'
+url='https://github.com/Versent/saml2aws'
+license=('MIT')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("https://github.com/versent/$_pkgname/releases/download/v$pkgver/saml2aws_${pkgver}_${_goos}_${_goarch}.tar.gz")
+sha256sums=('6cefaea1430e2ca0a1df4493c9f8ffe86436db826319998ff215c6331f0333dc')
+
+package() {
+ install -Dm 755 "$_pkgname" -t "$pkgdir/usr/bin"
+}