summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSZanko2023-11-21 17:20:27 +0100
committerSZanko2023-11-21 17:20:27 +0100
commit3ada97bd0cd9e674ac5471a50f9d1d270ee86c3e (patch)
tree5f8205ca65c0d86224cb7031c6cbeccbb211f67d /PKGBUILD
parentdf05551690b35aa2d32d93f08700d73d8748705e (diff)
downloadaur-3ada97bd0cd9e674ac5471a50f9d1d270ee86c3e.tar.gz
Fix Broken Url
Signed-off-by: SZanko <szanko@protonmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1741c708321c..2fcfb5aa69e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=samloader
pkgname=${_pkgname}-git
pkgver=r46.b20e1b1
-pkgrel=1
+pkgrel=2
pkgdesc="Download firmware for Samsung devices"
arch=('any')
url="https://github.com/martinetd/samloader"
@@ -11,13 +11,13 @@ license=('GPL3')
conflicts=('samloader')
depends=(
'python'
- 'python-setuptools'
'python-tqdm'
'python-pycryptodomex'
- 'python-pip'
)
makedepends=(
'git'
+ 'python-build'
+ 'python-installer'
)
source=(git+"${url}.git")
sha256sums=('SKIP')
@@ -29,10 +29,12 @@ pkgver() {
build() {
cd "${srcdir}/${_pkgname}"
- python setup.py build
+ sed -E -i "s/cloud-neofussvr.sslcs.cdngc.net/cloud-neofussvr.samsungmobile.com/g" samloader/fusclient.py
+ python3 -m build --wheel --skip-dependency-check --no-isolation
}
package() {
cd "$srcdir/$_pkgname"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ python3 -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm644 COPYING -t "${pkgdir}/usr/share/licenses/${pkgname}"
}