summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Birks2019-06-27 22:23:42 -0400
committerDavid Birks2019-06-27 22:23:42 -0400
commit6dc2bb604f9803b35201f9c1aca1e312ae04df14 (patch)
tree19ce8522135203b9c1b08834734fc1d2fb71c8c3 /PKGBUILD
downloadaur-6dc2bb604f9803b35201f9c1aca1e312ae04df14.tar.gz
Initial commit of 1.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..37498160c641
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: David Birks <david@tellus.space>
+
+pkgname=sanic
+pkgdesc='Command line tool for creating clusters on Amazon EKS'
+pkgver=1.0.0
+pkgrel=1
+arch=('x86_64')
+license=('Apache')
+url='https://github.com/weaveworks/eksctl'
+depends=('kubectl' 'docker')
+makedepends=('go')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/distributed-containers-inc/sanic/archive/v$pkgver.tar.gz")
+sha256sums=('4754b9392ae6f73f77249a1fa2d16672301375f3035a56f115a79043647a2dff')
+
+prepare() {
+ # Make fake gopath
+ mkdir -p gopath/src/github.com/distributed-containers-inc
+ ln -rTsf $pkgname-$pkgver gopath/src/github.com/distributed-containers-inc/sanic
+}
+
+build() {
+ # Trim PWD from binary
+ export GOFLAGS="-gcflags=all=-trimpath=${PWD} -asmflags=all=-trimpath=${PWD} -ldflags=-extldflags=-zrelro -ldflags=-extldflags=-znow"
+
+ export GOPATH="$srcdir"/gopath
+ export GO111MODULE=on
+ cd gopath/src/github.com/distributed-containers-inc/sanic
+ go install
+}
+
+package() {
+ install -Dm 755 "$srcdir/gopath/bin/$pkgname" "$pkgdir/usr/bin/$pkgname"
+}