diff options
author | dyredhead | 2024-07-08 00:42:54 -0400 |
---|---|---|
committer | dyredhead | 2024-07-08 00:42:54 -0400 |
commit | 7c5bd2e51b3547b175e239a48c044b12c35c20ab (patch) | |
tree | 8b321d8b449993db29883da94c08460385e81fa1 /PKGBUILD | |
parent | 0e9254822dc63ea958b1398dcd7df7d0493d32fd (diff) | |
download | aur-7c5bd2e51b3547b175e239a48c044b12c35c20ab.tar.gz |
added --frozen to cargo build to comply with Arch Rust package guidelines
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 9 |
1 files changed, 7 insertions, 2 deletions
@@ -14,12 +14,17 @@ conflicts=("$_pkgname" "${_pkgname}-bin") source=("git+https://github.com/Dyredhead/${_pkgname}.git") sha256sums=("SKIP") +prepare() { + export RUSTUP_TOOLCHAIN=stable + cargo fetch --locked --target "$(rustc -vV | sed -n 's/host: //p')" +} + build() { export RUSTUP_TOOLCHAIN=stable export CARGO_TARGET_DIR=target cd "$_pkgname" - cargo build --release --all-features + cargo build --release --all-features --frozen ./target/release/man ./target/release/completions } @@ -28,7 +33,7 @@ check() { export RUSTUP_TOOLCHAIN=stable cd "$_pkgname" - cargo test --all-features + cargo test --all-features --frozen } package() { |