summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorproninyaroslav2015-06-11 12:00:04 +0300
committerproninyaroslav2015-06-11 12:00:04 +0300
commit9f9d901ee6f61e4f878e04f9a663d5fa3eff0c7c (patch)
tree633a17e444800e29bd9024231fbe44a20fa4b426 /PKGBUILD
downloadaur-9f9d901ee6f61e4f878e04f9a663d5fa3eff0c7c.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..231324a6abcc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: yaroslav <proninyaroslav@mail.ru>
+# Contributor: V0K3 <v0k3@inventati.org>
+
+pkgname=sasm
+pkgver=3.1.4
+pkgrel=1
+pkgdesc="Simple crossplatform IDE for NASM, MASM, GAS, FASM assembly languages"
+arch=('i686' 'x86_64')
+url="http://dman95.github.io/SASM/english.html"
+license=('GPL3')
+depends=('qt4>=4.8' 'nasm' 'gdb' 'gcc')
+depends_x86_64+=('gcc-multilib')
+optdepends=(
+ 'nasmx: a collection of macros, include files and examples for linux, x11, gtk, opengl'
+)
+source=("https://github.com/Dman95/SASM/archive/v${pkgver}.tar.gz")
+md5sums=("c7cc0e7b834a8be13286ad48aefbd1a0")
+
+build() {
+ cd "${srcdir}/SASM-${pkgver}"
+ qmake PREFIX="${pkgdir}/usr"
+ make
+}
+
+package() {
+ cd "${srcdir}/SASM-${pkgver}"
+ make install
+}