summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrás Wacha2023-05-08 11:50:38 +0200
committerAndrás Wacha2023-05-08 11:50:38 +0200
commit2cff850357e2bc5e5c3982db801ce5738ce2f6ad (patch)
tree4d4fd1672d653e213c89a263152fa42cea0d7b3c /PKGBUILD
parent4aad79c8b78e0cfa71748a10a7db2b07e9a70a55 (diff)
downloadaur-2cff850357e2bc5e5c3982db801ce5738ce2f6ad.tar.gz
Version 5.0.5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 77af1e0c2a1b..e5fe1067788f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,6 +28,7 @@ depends=( python-setuptools
python-qt5reactor
python-service-identity
python-pytest
+ python-uncertainties
sasmodels
)
checkdepends=(python-unittest-xml-reporting)
@@ -35,13 +36,19 @@ checkdepends=(python-unittest-xml-reporting)
makedepends=(texlive-latexextra)
source=("$pkgname-$pkgver.tar.gz::https://github.com/SasView/sasview/archive/v${pkgver}.tar.gz"
'sphinx-docs.patch'
+ 'np_float_deprecated.patch'
)
-md5sums=('52da09f7ec3ea63c7d5ab4f7a989ef1f' 'SKIP')
-sha256sums=('8c92ecc113cf861f675a4ff5024920e036b58d178fd6e7afb77bd2fac41d5077' 'SKIP')
+md5sums=('52da09f7ec3ea63c7d5ab4f7a989ef1f'
+ '5bc096ee2c911545ba3251e308429c72'
+ '3334446106fe34caabe98a06c3bcbd82')
+sha256sums=('8c92ecc113cf861f675a4ff5024920e036b58d178fd6e7afb77bd2fac41d5077'
+ 'e1d8e107aa24ff06917b9ba2e8357818e6b1b90d91f36135dfbd051ca5b3184b'
+ '47566dc89dc3bf4e222d9fe2bff3bb71a62b8fdc4c7a652f9bb57d8702b25c11')
prepare() {
cd "${pkgname}-${pkgver}"
patch --forward --strip=1 --input="${srcdir}/sphinx-docs.patch"
+ patch --forward --strip=1 --input="${srcdir}/np_float_deprecated.patch"
}
build() {