summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjnanar2017-11-05 17:05:31 +0100
committerjnanar2017-11-05 17:05:31 +0100
commitef3f7e9d60c9ff913562e87b217159e5b30e0d9e (patch)
tree38c3bba9f9a6fd3d19c76b39a598608059bdcc7f /PKGBUILD
downloadaur-ef3f7e9d60c9ff913562e87b217159e5b30e0d9e.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1e0ca8d7818b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+#Maintainer: Arnaud Joset <info [AT] agayon [DOT] be>
+
+pkgname=('sat-tmp-hg')
+_realname=sat_tmp
+pkgver=0.7.r46.725ca928fa2c
+VERSION=0.7
+pkgrel=1
+url="https://salut-a-toi.org/"
+arch=('any')
+depends=('python2')
+makedepends=('')
+provides=('sat-tmp')
+conflicts=('sat-tmp')
+license=('AGPL3')
+source=("hg+https://repos.goffi.org/sat_tmp")
+md5sums=('SKIP')
+options=('!strip')
+
+pkgver() {
+ cd "$_realname"
+ printf "$VERSION.r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
+}
+
+
+
+package(){
+ pkgdesc="Sat_tmp aims to temporary store files needed by Salut-a-toi (sat). These monkey patchs are not merged upstream yet. For now, only wokkel is inpacted."
+ depends=('python2-jinja')
+
+ cd "$pkgdir"
+ install -dm755 "usr/lib/python2.7/site-packages/$_realname"
+ cd "$srcdir/$_realname/$_realname/"
+ cp -rv * "$pkgdir/usr/lib/python2.7/site-packages/$_realname"
+}
+