summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorValérie Roux2023-01-29 16:07:54 +0100
committerValérie Roux2023-01-29 16:07:54 +0100
commitb5628dae79a47e8779ba250119ee8b0d22eb44e1 (patch)
treeb4fc9d03f4db6b2747975970dce348c8b53606d6 /PKGBUILD
downloadaur-b5628dae79a47e8779ba250119ee8b0d22eb44e1.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ecbdaf585563
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+_name=satellite
+pkgname=satellite-gtk
+pkgver=0.3.1
+pkgrel=1
+pkgdesc="Displays Global Navigation Satellite System (GNSS: GPS, Galileo, Glonass etc.) information obtained from NMEA sources and saves your tracks"
+arch=('any')
+url="https://codeberg.org/tpikonen/$_name"
+license=('GPL3')
+depends=(python-gobject libhandy python-pydbus python-pynmea2 python-gpxpy)
+makedepends=(python-build python-installer python-wheel)
+optdepends=(modemmanager gnss-share)
+source=("https://codeberg.org/tpikonen/$_name/archive/$pkgver.tar.gz")
+sha512sums=('db6454c49aeb2932799772fa50c26ca1db7f11e77e612636e19045cb41df7a00b9d9e3a08a1bbd35fa41408ddda9a03dd721e3132fcfe799479b9632895335f1')
+
+
+build() {
+ cd "$_name"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "$_name"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}