summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStefan Husmann2016-02-14 19:56:57 +0100
committerStefan Husmann2016-02-14 19:56:57 +0100
commit784e252fc0d0724f022fc24f0dc7ad991ede416c (patch)
tree3c73e8696480b770ddd69bac82daf1e9ea23dcfd /PKGBUILD
parent712f819cc8310d0df14f3bb2d9fce52c0b603a3e (diff)
downloadaur-784e252fc0d0724f022fc24f0dc7ad991ede416c.tar.gz
patch poweroff.jl to user more sane defaults
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 942063daf878..03ad61e7a001 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,15 +4,16 @@
pkgname=sawfish
pkgver=1.11.90
-pkgrel=1
+pkgrel=2
pkgdesc="An extensible window manager using a Lisp-based scripting language"
arch=('i686' 'x86_64')
url="http://sawfish.wikia.com/wiki/Main_Page"
license=('GPL')
depends=('libsm' 'rep-gtk' 'hicolor-icon-theme')
install=${pkgname}.install
-source=(http://download.tuxfamily.org/${pkgname}/${pkgname}_${pkgver}.tar.xz)
-sha1sums=('092c088f0af8efe6fd603bd6e9b10f005615a65f')
+source=(http://download.tuxfamily.org/${pkgname}/${pkgname}_${pkgver}.tar.xz arch_poweroff_defaults.patch)
+sha1sums=('092c088f0af8efe6fd603bd6e9b10f005615a65f'
+ '73dbf5f93c0124c11f0254267d662f86be1f2767')
options=('!libtool')
build() {
@@ -21,6 +22,11 @@ build() {
make
}
+prepare() {
+ cd "${srcdir}/${pkgname}_${pkgver}"
+ patch -p1 < "$srcdir"/arch_poweroff_defaults.patch
+}
+
package() {
cd "${srcdir}/${pkgname}_${pkgver}"
make DESTDIR="${pkgdir}" install