summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhaawda2020-12-30 23:02:00 +0100
committerhaawda2020-12-30 23:02:00 +0100
commitcb8f325f6080b289850330c6134ed8a1c7f7a2b6 (patch)
tree4e18d27da06fd3d8d028978ac10453466d2e6fd8 /PKGBUILD
parent318f098790a643e6b18c51c44e9e17158402b891 (diff)
downloadaur-cb8f325f6080b289850330c6134ed8a1c7f7a2b6.tar.gz
avoid _gitname variable
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 01e6c21b3ee5..24ace85d85ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,30 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
pkgname=sawfish-session-dialog-git
-pkgver=20150813
+pkgver=20190126
pkgrel=1
pkgdesc="A graphical Sawfish extension to edit the session preferences"
arch=('any')
url='http://sawfish.wikia.com'
license=('GPL')
-depends=('sawfish-git')
+depends=('sawfish')
makedepends=('git')
provides=('sawfish-session-dialog=0.41')
conflicts=('sawfish-session-dialog')
source=('sawfish-session-dialog::git://github.com/SawfishWM/ssd.git')
md5sums=('SKIP')
-_gitname=sawfish-session-dialog
pkgver() {
- cd "$srcdir"/$_gitname
+ cd ${pkgname%-git}
echo $(git log -1 --format="%cd" --date=short | sed 's|-||g')
}
build() {
- cd "$srcdir"/$_gitname
+ cd ${pkgname%-git}
./configure --prefix=/usr
}
package() {
- cd "$srcdir"/$_gitname
- make DESTDIR=$pkgdir install
+ cd ${pkgname%-git}
+ make DESTDIR="$pkgdir" install
}