summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLeonard König2015-08-31 15:27:16 +0200
committerLeonard König2015-08-31 15:27:16 +0200
commit166f0464b589e87ae32829190d734840aa8b663d (patch)
treead0ddde3f484ab825abb5d9e7a88f81d79a03d92 /PKGBUILD
parent6032c77693d1a5fc8dbff79102c218005db2f7f9 (diff)
downloadaur-166f0464b589e87ae32829190d734840aa8b663d.tar.gz
updated deps to qt5, added other deps, removed deps, cleanup
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 21 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f0a6c78df92c..ae3a93fdd1cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,23 @@
#Maintainer: Leonard König <leonard dot r dot koenig at googlemail dot com>
pkgname=sayonara-player-svn
-pkgver=r1092
-pkgrel=2
+pkgver=r1194
+pkgrel=1
pkgdesc="Sayonara is a small, clear and fast audio player for Linux written in C++, supported by the Qt framework. It uses Gstreamer as audio backend."
-arch=('any')
+arch=('i686' 'x86_64')
url="https://sayonara-player.com/"
license=('GPL3')
-depends=('qt4' 'curl' 'taglib' 'gst-plugins-base' 'gst-plugins-good' 'libnotify')
+depends=('qt5-base'
+ 'gst-plugins-base'
+ 'gst-plugins-good'
+ 'gst-plugins-bad'
+ 'libnotify'
+ 'hicolor-icon-theme')
+# taglib not needed as it is already covered by gst-plugins-good dependency
+# hicolor theme for the icon structure
optdepends=('lame: mp3 converter, broadcasting'
'gst-plugins-ugly: mp3 converter, broadcasting')
-makedepends=('subversion' 'cmake')
+makedepends=('subversion' 'cmake' 'desktop-file-utils' 'xdg-utils')
+# desktop-file-utils and xdg-utils needed for MIME and icon DB
conflicts=('sayonara-player')
install=sayonara-player-svn.install
source=($pkgname::svn+http://sayonara-player.com/svn/sayonara/trunk)
@@ -17,22 +25,23 @@ md5sums=('SKIP')
pkgver() {
cd "$pkgname"
- # workaround the reset of the svn-version...
+ # Workaround the reset of the svn-version:
+ # The package uses a workaround that adds 1042 to the revision number, as due to source-transfer
+ # the revision counter got reset. So while the svn-revision is ~50, the actual version is much higher.
local sver=$(svnversion)
local ver=$(($sver + 1042))
printf "r%s" "${ver//[[:alpha:]]}"
}
build() {
-# msg "$PWD"
-# msg "$pkgname"
-# msg "$ls"
cd "$pkgname"
- cmake . -DCMAKE_INSTALL_PREFIX=/usr
+ mkdir build
+ cd build
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE="Release"
make
}
package() {
- cd "$SRCDEST/$pkgname"
- make prefix=/usr DESTDIR="$pkgdir/" install
+ cd "$pkgname/build"
+ make DESTDIR="$pkgdir/" install
}