summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlucas593562019-01-31 09:42:43 -0200
committerlucas593562019-01-31 09:42:43 -0200
commitf10b0d0c60b45841199fdb6d501230e8673e0ff7 (patch)
tree1f5f9e7c3cc4fbe34a799ea78aa4c0301e0277ee /PKGBUILD
downloadaur-f10b0d0c60b45841199fdb6d501230e8673e0ff7.tar.gz
First working
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f15e954f2cb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer:Lucas Eduardo Wendt <lucas59356@gmail.com>
+
+pkgname=sbcli-git
+depends=('sbcl' 'quicklisp')
+pkgrel=1
+pkgver=r24.de774ef
+arch=(any)
+pkgdesc="A better REPL for SBCL"
+license=("gpl3")
+options=(!strip)
+url="https://github.com/hellerve/sbcli"
+source=("git+https://github.com/lucasew/sbcli")
+sha256sums=("SKIP")
+
+# if /usr/bin/env: “sbcl --script”: File or directory not found change hellerve to lucasew on source
+
+pkgver() {
+ cd "$srcdir/sbcli"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/local/bin"
+ cp "$srcdir/sbcli/repl.lisp" "$pkgdir/usr/local/bin/sbcli"
+}